freebsd man page for devclass_get_device

Query: devclass_get_device

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVCLASS_GET_DEVICE(9)					   BSD Kernel Developer's Manual				    DEVCLASS_GET_DEVICE(9)

NAME
devclass_get_device -- translate unit number to device
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> device_t devclass_get_device(devclass_t dc, int unit);
DESCRIPTION
This function retrieves the device instance with the given unit number and returns it.
RETURN VALUES
If the device exists, it is returned, otherwise NULL is returned.
SEE ALSO
devclass(9), device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
devclass(9) - freebsd
devclass(9) - linux
device_add_child(9) - linux
devclass(9) - opensolaris
devclass(9) - osx
Similar Topics in the Unix Linux Community
Unix File Permissions
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Is UNIX an open source OS ?
UNIX Environment Setup - (Just starting!)