freebsd man page for bus_generic_shutdown

Query: bus_generic_shutdown

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUS_GENERIC_SHUTDOWN(9) 				   BSD Kernel Developer's Manual				   BUS_GENERIC_SHUTDOWN(9)

NAME
bus_generic_shutdown -- generic implementation of DEVICE_SHUTDOWN for busses
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int bus_generic_shutdown(device_t dev);
DESCRIPTION
This function provides an implementation of the DEVICE_SHUTDOWN(9) method which can be used by most bus code. It simply calls the DEVICE_SHUTDOWN(9) method of each child device attached to the bus.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
device(9), driver(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device_attach(9) - debian
device_detach(9) - debian
device_identify(9) - freebsd
device_detach(9) - linux
device_detach(9) - minix
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Scripts without shebang
Memory Leaks
Is UNIX an open source OS ?
A simple UNIXtime component in Vue.js