freebsd man page for bus_generic_attach

Query: bus_generic_attach

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUS_GENERIC_ATTACH(9)					   BSD Kernel Developer's Manual				     BUS_GENERIC_ATTACH(9)

NAME
bus_generic_attach -- generic implementation of DEVICE_ATTACH for busses
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int bus_generic_attach(device_t dev);
DESCRIPTION
This function provides an implementation of the DEVICE_ATTACH(9) method which can be used by most bus code. It simply calls device_probe_and_attach(9) for each child device attached to the bus.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
device(9), driver(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device_identify(9) - debian
device_attach(9) - freebsd
device_detach(9) - freebsd
device_attach(9) - linux
device_attach(9) - minix
Similar Topics in the Unix Linux Community
Unix File Permissions
Mac OS X: Based on UNIX - Solid As a Rock
The Whole Story on #! /usr/bin/ksh
Valid separator in time and date format