freebsd man page for buf_lockfree

Query: buf_lockfree

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUF_LOCKFREE(9) 					   BSD Kernel Developer's Manual					   BUF_LOCKFREE(9)

NAME
BUF_LOCKFREE -- destroys a buffer's lock
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> void BUF_LOCKFREE(struct buf *bp);
DESCRIPTION
The BUF_LOCKFREE() macro destroys the buffer lock. The lock must not be held when this macro is called or a panic will result. Its argument is: bp The buffer whose lock is to be destroyed.
SEE ALSO
buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockdestroy(9)
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 9, 2001 BSD
Related Man Pages
uidinfo(9) - debian
uihold(9) - debian
uihashinit(9) - debian
getpbuf(9) - freebsd
relpbuf(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
The Whole Story on #! /usr/bin/ksh
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?