Query: buf_lock
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
BUF_LOCK(9) BSD Kernel Developer's Manual BUF_LOCK(9)NAMEBUF_LOCK -- locks a bufferSYNOPSIS#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> int BUF_LOCK(struct buf *bp, int locktype);DESCRIPTIONThe BUF_LOCK() function locks the given buffer. If the lock is already held this call will block until it can acquire the lock unless LK_NOWAIT is set. Its arguments are: bp The buffer to lock. locktype Flags controlling the type of lock. See lockmgr(9) for details.RETURN VALUESA value of 0 is returned upon success. See lockmgr(9) for information on non-zero return values.SEE ALSObuf(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockmgr(9)AUTHORSThis manual page was written by Chad David <davidc@acns.ab.ca>.BSDJuly 9, 2001 BSD
Related Man Pages |
---|
lockdestroy(9) - debian |
lock(9) - debian |
lockmgr_assert(9) - debian |
lockmgr_recursed(9) - debian |
lockmgr_waiters(9) - debian |
Similar Topics in the Unix Linux Community |
---|
Unix File Permissions |
Scripts without shebang |
Reason for no directory creation date |
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD? |
Controlling user input |