WATCHDOG(8) BSD System Manager's Manual WATCHDOG(8)NAME
watchdog -- watchdog control program
watchdog [-d] [-t timeout]
The watchdog utility can be used to control the kernel's watchdog facility.
The -d option enables debugging.
The -t timeout option specifies the desired timeout period in seconds, a value of zero will disable the watchdog. The default timeout is 128
SEE ALSO watchdog(4), watchdogd(8), watchdog(9)HISTORY
The watchdog utility appeared in FreeBSD 5.1.
The watchdog utility and manual page were written by Sean Kelly <smkelly@FreeBSD.org> and Poul-Henning Kamp <phk@FreeBSD.org>.
Some contributions made by Jeff Roberson <jeff@FreeBSD.org>.
BSD October 18, 2014 BSD
Check Out this Related Man Page
WATCHDOG(9) BSD Kernel Developer's Manual WATCHDOG(9)NAME
watchdog -- software and hardware watchdog facility
watchdog_fn(void *private, u_int cmd, int *error);
EVENTHANDLER_REGISTER(watchdog_list, watchdog_fn, private, 0);
To implement a watchdog in software or hardware, only a single function needs to be written and registered on the global watchdog_list.
The function must examine the cmd argument and act on it as follows:
If cmd is zero, the watchdog must be disabled and the error argument left untouched. If the watchdog cannot be disabled, the error argument
must be set to EOPNOTSUPP.
Else the watchdog should be reset and configured to a timeout of (1 << (cmd & WD_INTERVAL)) nanoseconds or larger and the error argument be
set to zero to signal arming of a watchdog.
If the watchdog cannot be configured to the proposed timeout, it must be disabled and the error argument left as is (to avoid hiding the arm-
ing of another watchdog).
There is no specification of what the watchdog should do when it times out, but a hardware reset or similar ``drastic but certain'' behaviour
SEE ALSO watchdog(4)AUTHORS
The watchdog facility and this manual page was written Poul-Henning Kamp <phk@FreeBSD.org>.
BSD February 28, 2004 BSD
My Unix Server with SCO Unix ver 5, display Watchdog error which reads,
Watchdog ReInitMemory 6 for board 0 Warning : eeE : Allocb failure in ReInitMemory.
My server has 98 dumb terminals connected. It has 5 Hard Disks (SCSI) of 9.1 GB each and 512 MB RAM. Uses RAID level 5
After this error... (1 Reply)
I'm trying to get a watchdog module working on a server. (Watchdog timers are little hardware devices that reboot the system if it becomes unresponsive.) The module takes some options like the timeout til reboot, what power action to take, etc. I've set these options up in... (4 Replies)
is there something build in solaris that can act as "watchdog".
I have some process (service) running (e.g. Rhino). It can happen that if freezes totaly so I need to find this out and restart it totaly.
My vision is two possibilities.
1) there is some counter running and I will... (2 Replies)
Please let me know what is hardware watchdog enabled which we get when the solaris host is booting .As per my knowledge its the one states that the POST is enabled. correct me if am wrong. (1 Reply)
I am getting pages from EMS(Event Monitoring Servers) for "no watchdog notification"
I just wonder what cause this and what to look in the system.
this error was generated from production lpar which hosts p570
Mann (4 Replies)
I am willing to build a script that does a "ps-ef" or "top" on a specific process, and if it finds it running to start another process.
Any suggestions to do this in a optimized way?
Thanks! (2 Replies)