WAKE(8) BSD System Manager's Manual WAKE(8)NAME
wake -- send Wake on LAN frames to hosts on a local Ethernet network
wake [interface] lladdr [lladdr ...]
The wake program is used to send Wake on LAN (WoL) frames over a local Ethernet network to one or more hosts using their link layer (hard-
ware) addresses. WoL functionality is generally enabled in a machine's BIOS and can be used to power on machines from a remote system with-
out having physical access to them.
interface is an Ethernet interface of the local machine and is used to send the Wake on LAN frames over it. If there is only one Ethernet
device available that is up and running, then the interface argument can be omitted. lladdr is the link layer address of the remote machine.
This can be specified as the actual hardware address (six hexadecimal numbers separated by colons) or as a hostname entry in /etc/ethers.
wake accepts multiple lladdr addresses. Link layer addresses can be determined and set using ifconfig(8).
/etc/ethers Ethernet host name data base.
SEE ALSO ethers(5), ifconfig(8)AUTHORS
wake was written by Marc Balmer <firstname.lastname@example.org>.
BSD December 27, 2009 BSD
Check Out this Related Man Page
ethers(4) File Formats ethers(4)NAME
ethers - Ethernet address to hostname database or domain
The ethers file is a local source of information about the (48-bit) Ethernet addresses of hosts on the Internet. The ethers file can be
used in conjunction with or instead of other ethers sources, including the NIS maps ethers.byname and ethers.byaddr, the NIS+ table ethers,
or Ethernet address data stored on an LDAP server. Programs use the ethers(3SOCKET) routines to access this information.
The ethers file has one line for each host on an Ethernet. The line has the following format:
Items are separated by any number of SPACE and/or TAB characters. A `#' indicates the beginning of a comment extending to the end of line.
The standard form for Ethernet addresses is "x:x:x:x:x:x" where x is a hexadecimal number between 0 and ff, representing one byte. The
address bytes are always in network order. Host names may contain any printable character other than SPACE, TAB, NEWLINE, or comment char-
SEE ALSO ethers(3SOCKET), hosts(4), nsswitch.conf(4)SunOS 5.11 22 Jul 2004 ethers(4)
Is there an easy way (besides samba) to send a file from a unix server to a win98 machine across a network. I am on a SCO server and need to send the file to a windows machine so the program on the machine does not keep on looking for it on my server. It checks for a new file every couple of... (5 Replies)
My network layout is:
+ telnet srv on HP-UX 10.x box
+ other services (http, pop3, smtp, ftp)...
I've the following problem:
Inside Internal LAN I can connect myself to HP-UX telnet but from Public LAN in some place is refusing me... (5 Replies)
m old to Unix but new to scripting
I have a MacBook running osx that I want to use as an nfs client. The server will be a linux box with a wake on lan card. Here's the idea. Run a cron command on the mac every minute that checks if I am on my home wireless network (the linux box is wired to... (6 Replies)
In Ultra 10 at time system is not displaying value for Ethernet address and Host ID.
Also, when i am trying to change the value of environment variables i am getting below message and value is not changing
Thanks (4 Replies)
I have problem with my application. Application is running on embedded Linux machine. It's basically multiprotocol gateway that connects two industrial Ethernet networks.
We are experiencing some kind of application hang every 2 to 3 days. It seems like both threads are still running but... (12 Replies)
Hi everyone! I want to be able to send a signal to another machine on the same network, and have it trigger a script on that machine. Here's the reason why I can't just ssh: I don't have a username on that machine, but there is a user that is always logged on that I can do stuff on.
So, I want... (5 Replies)
i want to set ip address to a vitrual machine i am using following command.
but it is not ifconfig -a command output.
what is wrong i dont know
bash# ifconfig interfacename plumb
bash# ifconfig interfacename auto-dhcp
Please use code tags next time for your code and data. (4 Replies)
I want to find another(Local host) machine IP address from my machine.. We are all connected in the same server, I mean same LAN.
What i done is
Connected with that user machine using SSH and SU.. After that i used IFCONFIG but it shows my Ip address. Can not able to get the... (8 Replies)
I am using ubuntu 12.04.03. I have some basic experience with webpy and I had it working for my LAN just by following the tutorial. The framework needs to be able to be used from outside the local network. I have difficulty seeing how to make the framework accessible from outside the lan. I tried... (10 Replies)
I am using an F5 LTM Load balancer VM. Its network config is as follows:
eth0 Link encap:Ethernet HWaddr 00:50:56:01:01:FA
inet addr:192.168.2.104 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::250:56ff:fe01:1fa/64 Scope:Link
UP... (3 Replies)
I have a problem with the transfer speed between 2 hosts on my local network (LAN).
At home, I have a switch (NETGEAR GS105 ProSafe 5-Port Gigabit Ethernet Desktop Switch) which obviously supports Gigabit Ethernet, 2 boxes (intel NUC DC3217IYE Barebone PC and Gygabyte BRIX GB-XM12... (7 Replies)
I have a machine in my LAN that runs Ubuntu and I have full access in it.
There is another PC on the Internet that has a public IP eg 18.104.22.168 and it servers as https server and access to it is by username and password. On the remote PC all i have is access through https using username/passwd.
... (3 Replies)