LOCATE.UPDATEDB(8) BSD System Manager's Manual LOCATE.UPDATEDB(8)NAME
locate.updatedb -- update locate database
The locate.updatedb utility updates the database used by locate(1). It is typically run once a week by the /etc/periodic/weekly/310.locate
The contents of the newly built database can be controlled by the /etc/locate.rc file.
LOCATE_CONFIG path to the configuration file
/var/db/locate.database the default database
/etc/locate.rc the configuration file
SEE ALSO locate(1), periodic(8)
Woods, James A., "Finding Files Fast", ;login, 8:1, pp. 8-10, 1983.
BSD February 11, 1996 BSD
Check Out this Related Man Page
LOCATE.CONF(5) BSD File Formats Manual LOCATE.CONF(5)NAME
locate.conf -- locate database configuration file
The locate.conf file specifies the behavior of locate.updatedb(8), which creates the locate(1) database.
The locate.conf file contains a list of newline separated records, each of which is composed of a keyword and arguments, which are separated
by white space. Arguments with embedded shell metacharacters must be quoted in sh(1) style. Lines beginning with ``#'' are treated as com-
ments and ignored. However, a ``#'' in the middle of a line does not start a comment.
The configuration options are as follows:
ignore pattern ...
Ignore files or directories. When building the database, do not descend into files or directories which match one of the specified
patterns. The matched files or directories are not stored to the database.
Default: Not specified.
ignorecontents pattern ...
Ignore contents of directories. When building the database, do not descend into files or directories which match one of the speci-
fied patterns. The matched files or directories themselves are stored to the database.
Default: Not specified.
ignorefs type ...
Ignore file system by type, adding type to the default list. When building the database, do not descend into file systems which are
of the specified type. The mount points are not stored to the database. If a ``!'' is prepended to type, the meaning is negated,
that is, ignore file systems which do not have the type. As a special case, if ``none'' is specified for type, the ignorefs list is
cleared and all file systems are traversed.
type is used as an argument to find(1)-fstype. The sysctl(8) command can be used to find out the types of file systems that are
available on the system:
Default: !local cd9660 fdesc kernfs procfs
searchpath directory ...
Specify base directories to be put in the database.
Specify the working directory of locate.updatedb, in which a temporary file is placed. The temporary file is a list of all files,
and you should specify a directory that has enough space to hold it.
Refer to find(1) for the details of pattern (see -path expression) and type (see -fstype expression).
/etc/locate.conf The file locate.conf resides in /etc.
SEE ALSO find(1), locate(1), locate.updatedb(8), sysctl(8)HISTORY
The locate.conf file format first appeared in NetBSD 2.0.
BSD July 10, 2011 BSD
I want to get the entire path of a file.
I am in root directory and i know the file name, However dont know the path where it is.
Please tell me the command to get the entire path for the file?
Thanks in advance,
Rashmy. (14 Replies)
I have some files that I want to locate using the locate command in terminal, but my home folder is encrypted using FileVault from Mac OS X 10.6.
Any idea how can I locate them, being my home encrypted? (8 Replies)
Can anyone help me with this error?
sudo yum install perl-Gtk2-WebKit
Loaded plugins: langpacks, presto, refresh-packagekit, versionlock
Setting up Install Process
--> Running transaction check
---> Package perl-Gtk2-WebKit.i686 0:0.09-1.fc15 will be installed
-->... (0 Replies)
Any good suggestion concerning this BASH search script?
#Any good suggestions for this simple search shell?
echo "Enter File Name for search"
echo No such file... (1 Reply)
HI when ever i type the locate command it is saying like below
warning: locate: warning: database /var/lib/slocate/slocate.db' is more than 8 days old
i am using Linux .
version is as follows...
$ uname -a
Linux abc.abc.com 2.6.9-89.35.1.ELhugemem #1 SMP Tue Jan 4... (3 Replies)
I'm using a RaspberryPi with standard Raspbian.
Currently I'm working on some sort of weather station.
For now I have three python scripts - one which is updating txt files for website - update1m.py ( it will not be necessary in few next days so I'll delete it) , second one for updating... (4 Replies)
I have a wired string pattern ( mongo output) which I need to convert to only values.
"_id" : ObjectId("59280d9b95385c78b73252e4"), "categorySetId" : NumberLong(1100000041), "categorySetName" : "PROD GROUP", "serviceableProductFlag" : "N", "categoryId" : NumberLong(1053), "pid" :... (5 Replies)
Can somebody please show me how to check from within a KSH script if a directory exists on that same host when parts of the directory tree are unknown?
If these wildcard dirs were the only dirs at that level then ...
RETCODE=$(ls -l /u01/app/oracle/local/*/* | grep target_dir) ... will... (4 Replies)
I had some code in place to update the MySQL man page DB 'on the fly' but this database has grown so big over time (now over 7 GB, 7.1 GB to be exact) that the update query was causing the man page rendering to slow down to a crawl.
So, I just disabled updating the table 'on the fly' so the... (1 Reply)