TRPT(8) BSD System Manager's Manual TRPT(8)NAME
trpt -- transliterate protocol trace
trpt [-a] [-f] [-j] [-p hex-address] [-s] [-t] [system [core]]
The trpt utility interrogates the buffer of TCP trace records created when a socket is marked for ``debugging'' (see setsockopt(2)), and
prints a readable description of these records. When no options are supplied, trpt prints all the trace records found in the system grouped
according to TCP connection protocol control block (PCB).
The following options may be used to alter this behavior:
-a In addition to the normal output, print the values of the source and destination addresses for each packet recorded.
-f Follow the trace as it occurs, waiting a short time for additional records each time the end of the log is reached.
-j Just give a list of the protocol control block addresses for which there are trace records.
-p Show only trace records associated with the protocol control block at the given address hex-address.
-s In addition to the normal output, print a detailed description of the packet sequencing information.
-t In addition to the normal output, print the values for all timers at each point in the trace.
The recommended use of trpt is as follows. Isolate the problem and enable debugging on the socket(s) involved in the connection. Find the
address of the protocol control blocks associated with the sockets using the -A option to netstat(1). Then run trpt with the -p option, sup-
plying the associated protocol control block addresses. The -f option can be used to follow the trace log once the trace is located. If
there are many sockets using the debugging option, the -j option may be useful in checking to see if any trace records are present for the
socket in question.
If debugging is being performed on a system or core file other than the default, the last two arguments may be used to supplant the defaults.
no namelist When the system image does not contain the proper symbols to find the trace buffer; others which should be self explanatory.
SEE ALSO netstat(1), setsockopt(2)HISTORY
The trpt utility appeared in 4.2BSD.
Should also print the data for each input or output, but this is not saved in the trace record.
The output format is inscrutable and should be described here.
BSD December 11, 1993 BSD
Check Out this Related Man Page
NETSTAT(1) General Commands Manual NETSTAT(1)NAME
netstat - show network status
netstat [ -Aan ] [ -f address_family ] [ system ] [ core ]
netstat [ -himnrs ] [ -f address_family ] [ system ] [ core ]
netstat [ -n ] [ -I interface ] interval [ system ] [ core ]
The netstat command symbolically displays the contents of various network-related data structures. There are a number of output formats,
depending on the options for the information presented. The first form of the command displays a list of active sockets for each protocol.
The second form presents the contents of one of the other network data structures according to the option selected. Using the third form,
with an interval specified, netstat will continuously display the information regarding packet traffic on the configured network inter-
The options have the following meaning:
-A With the default display, show the address of any protocol control blocks associated with sockets; used for debugging.
-a With the default display, show the state of all sockets; normally sockets used by server processes are not shown.
-h Show the state of the IMP host table.
-i Show the state of interfaces which have been auto-configured (interfaces statically configured into a system, but not located at
boot time are not shown).
Show information only about this interface; used with an interval as described below.
-m Show statistics recorded by the memory management routines (the network manages a private pool of memory buffers).
-n Show network addresses as numbers (normally netstat interprets addresses and attempts to display them symbolically). This option
may be used with any of the display formats.
-s Show per-protocol statistics.
-r Show the routing tables. When -s is also present, show routing statistics instead.
Limit statistics or address control block reports to those of the specified address family. The following address families are rec-
ognized: inet, for AF_INET, ns, for AF_NS, and unix, for AF_UNIX.
The arguments, system and core allow substitutes for the defaults ``/vmunix'' and ``/dev/kmem''.
The default display, for active sockets, shows the local and remote addresses, send and receive queue sizes (in bytes), protocol, and the
internal state of the protocol. Address formats are of the form ``host.port'' or ``network.port'' if a socket's address specifies a net-
work but no specific host address. When known the host and network addresses are displayed symbolically according to the data bases
/etc/hosts and /etc/networks, respectively. If a symbolic name for an address is unknown, or if the -n option is specified, the address is
printed numerically, according to the address family. For more information regarding the Internet ``dot format,'' refer to inet(3N).
Unspecified, or ``wildcard'', addresses and ports appear as ``*''.
The interface display provides a table of cumulative statistics regarding packets transferred, errors, and collisions. The network
addresses of the interface and the maximum transmission unit (``mtu'') are also displayed.
The routing table display indicates the available routes and their status. Each route consists of a destination host or network and a
gateway to use in forwarding packets. The flags field shows the state of the route (``U'' if ``up''), whether the route is to a gateway
(``G''), and whether the route was created dynamically by a redirect (``D''). Direct routes are created for each interface attached to the
local host; the gateway field for such entries shows the address of the outgoing interface. The refcnt field gives the current number of
active uses of the route. Connection oriented protocols normally hold on to a single route for the duration of a connection while connec-
tionless protocols obtain a route while sending to the same destination. The use field provides a count of the number of packets sent
using that route. The interface entry indicates the network interface utilized for the route.
When netstat is invoked with an interval argument, it displays a running count of statistics related to network interfaces. This display
consists of a column for the primary interface (the first interface found during autoconfiguration) and a column summarizing information
for all interfaces. The primary interface may be replaced with another interface with the -I option. The first line of each screen of
information contains a summary since the system was last rebooted. Subsequent lines of output show values accumulated over the preceding
SEE ALSO iostat(1), vmstat(1), hosts(5), networks(5), protocols(5), services(5), trpt(8C)BUGS
The notion of errors is ill-defined. Collisions mean something else for the IMP.
4.2 Berkeley Distribution May 8, 1986 NETSTAT(1)