PROCCTL(8) BSD System Manager's Manual PROCCTL(8)NAME
procctl -- clear procfs event flags
SYNOPSIS
procctl pid ...
DESCRIPTION
The procctl utility clears the procfs(5) event mask used by truss(1). This can be used in the event that a process is left stranded, since
the procfs(5) events result in a non-killable process. The arguments are a list of process IDs; procctl goes through the list and clears the
event masks for each specified process.
SEE ALSO truss(1), procfs(5)HISTORY
The procctl utility was written by Sean Eric Fagan for FreeBSD.
BSD November 23, 1997 BSD
Check Out this Related Man Page
LINPROCFS(5) BSD File Formats Manual LINPROCFS(5)NAME
linprocfs -- Linux process file system
SYNOPSIS
linproc /compat/linux/proc linprocfs rw 0 0
DESCRIPTION
The Linux process file system, or linprocfs, emulates a subset of Linux' process file system and is required for the complete operation of
some Linux binaries.
The linprocfs provides a two-level view of process space. At the highest level, processes themselves are named, according to their process
ids in decimal, with no leading zeros. There is also a special node called self which always refers to the process making the lookup
request.
Each node is a directory containing several files:
exe A reference to the vnode from which the process text was read. This can be used to gain access to the process' symbol table, or to
start another copy of the process.
mem The complete virtual memory image of the process. Only those addresses which exist in the process can be accessed. Reads and writes
to this file modify the process. Writes to the text segment remain private to the process.
Each node is owned by the process's user, and belongs to that user's primary group, except for the mem node, which belongs to the kmem group.
FILES
/compat/linux/proc The normal mount point for the linprocfs.
/compat/linux/proc/cpuinfo CPU vendor and model information in human-readable form.
/compat/linux/proc/meminfo System memory information in human-readable form.
/compat/linux/proc/pid A directory containing process information for process pid.
/compat/linux/proc/self A directory containing process information for the current process.
/compat/linux/proc/self/exe The executable image for the current process.
/compat/linux/proc/self/mem The complete virtual address space of the current process.
EXAMPLES
To mount a linprocfs file system on /compat/linux/proc:
mount -t linprocfs linproc /compat/linux/proc
SEE ALSO mount(2), unmount(2), procfs(5), pseudofs(9)HISTORY
The linprocfs first appeared in FreeBSD 4.0.
AUTHORS
The linprocfs was derived from procfs by Pierre Beyssac. This manual page was written by Dag-Erling Smorgrav, based on the procfs(5) manual
page by Garrett Wollman.
BSD August 10, 1994 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)