PC-SYSINSTALL(8) BSD System Manager's Manual PC-SYSINSTALL(8)
pc-sysinstall -- System installer backend
pc-sysinstall [-c file] [command]
The pc-sysinstall utility is a hybrid backend for installing FreeBSD. When run in install mode it takes a configuration file and performs an
installation according to the parameters specified in the configuration file. When called with one of the system query commands it provides
information about the system to aid a front end in building an appropriate configuration file.
The following options are available:
Perform an installation as directed by file.
The command can be any one of the following:
help Display a list of all commands.
Display the help data for the specified command.
Provide a listing of the storage devices detected on this system.
Queries the specified storage device and returns information about its partitions.
Returns information about a storage device's size, cylinders, heads, and sectors.
Tests to see if this system is a laptop or desktop.
Tests to see if this system is running in an emulator
Returns a listing of the detected network cards on this system.
Returns a listing of the available components which can be installed.
list-rsync-backups user host port
Returns a listing of available rsync-backups on the target server in the life-preserver/ directory.
Returns a listing of available timezones.
Returns a list of languages that the installer supports.
Returns the size of installed system RAM in MegaBytes.
test if an internet connection is available.
Returns a list of PC-BSD and FreeBSD installs on this system for updates.
Returns a list of keyboard layouts that xorg supports.
Returns a list of keyboard models that xorg supports.
Returns a list of keyboard variants that xorg supports.
create-part disk size
Create a new MBR primary slice on the target disk using size MB.
Delete the disk partition specified. If this is the last partition, the disk partition layout will also be scrubbed, leaving a clean
disk ready for MBR or GPT file system layouts.
Start an automated installation with the specified file. Normally only used by automated install scripts.
setup-ssh-keys user host port
Setup SSH without a password for the target host, user, and port. Used to prompt the user to log into a server before doing a rsync
+ ssh restore.
This version of pc-sysinstall first appeared in FreeBSD 9.0.
Kris Moore <kmoore@FreeBSD.org>
This utility was written to install PC-BSD and has seen limited use as an installer for FreeBSD. It's likely that usage to install FreeBSD
will expose edge cases that PC-BSD doesn't, as well as generate feature requests based on unforeseen needs.
June 24, 2010 BSD