PAM_CHROOT(8) BSD System Manager's Manual PAM_CHROOT(8)NAME
pam_chroot -- Chroot PAM module
[service-name] module-type control-flag pam_chroot [arguments]
The chroot service module for PAM chroots users into either a predetermined directory or one derived from their home directory. If a user's
home directory as specified in the passwd structure returned by getpwnam(3) contains the string ``/./'', the portion of the directory name to
the left of that string is used as the chroot directory, and the portion to the right will be the current working directory inside the chroot
tree. Otherwise, the directories specified by the dir and cwd options (see below) are used.
also_root Do not hold user ID 0 exempt from the chroot requirement.
always Report a failure if a chroot directory could not be derived from the user's home directory, and the dir option was not specified.
Specify the directory to chdir(2) into after a successful chroot(2) call.
Specify the chroot directory to use if one could not be derived from the user's home directory.
SEE ALSO pam.conf(5), pam(8)AUTHORS
The pam_chroot module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Division
of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program.
BSD February 10, 2003 BSD
Check Out this Related Man Page
PAM_LOGIN_ACCESS(8) BSD System Manager's Manual PAM_LOGIN_ACCESS(8)NAME
pam_login_access -- login.access PAM module
[service-name] module-type control-flag pam_login_access [options]
The login.access service module for PAM provides functionality for only one PAM category: account management. In terms of the module-type
parameter, this is the ``account'' feature.
Login.access Account Management Module
The login.access account management component (pam_sm_acct_mgmt()), returns success if and only if the user is allowed to log in on the spec-
ified tty (in the case of a local login) or from the specified remote host (in the case of a remote login), according to the restrictions
listed in /etc/login.access.
SEE ALSO login.access(5), pam.conf(5), pam(8)AUTHORS
The login.access(5) access control scheme was designed and implemented by Wietse Venema.
The pam_login_access module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research
Division of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program.
BSD January 24, 2002 BSD
I need to restrict users shell access to only $HOME under /home for each user. I don't want them getting out of their own directories. From what I understand chroot is something I could use, but I want to avoid this since it involves creating symbolic links to a number... (9 Replies)
Please let me know the significance of . and .. directories in a file system.
One of my current file system doesn;t hv .. directory and i can run this command
du -k .
no permission in the current directory.
sita (8 Replies)
I would like to know how to find out the home directory of a particular user..
If am the root , then my Home directory will be /
if say am just a user logging into the terminal then my home dir would change,
so accordingly i would like to know how to find it out...
I know that... (7 Replies)
can anyone tell me how to display the permissions of a users home directory.
can i use ls -l but it only gives the permissions of the files and directories inside the directory..:confused::confused::confused::confused: (9 Replies)
I am using RHEL 5.0
I need a user say test to have full access to two directories, say /tmp1 & /tmp2 only other than his home directory.
I do not want to change his login shell which is ksh or bash by default.
Moreover, he should not even have read access of other directories.
... (10 Replies)
I need to rename a directory in every home directory on a given workstation. I am a newb to scripting so maybe thats why I cant exactly figure out how to correctly do this.
The first thing I need to be able to do to write this script is figure out how to list all the directorys (these are not... (11 Replies)
i'm using FreeBSD 6.2 and hosting my pc to frens
in particular of sensitive information being saved to the PC, i would like to know is it possible for me to restrict user access to their /home dir. only?
and also, i wanted to restrict them listing files under /etc
thanks all! (10 Replies)
specifically - I don't need to restrict a user to a single directory - but I want them to be "ROOTED" to their home directory.
so if my home directory is /home/onlyme
when I login - if I do a pwd - I want to see:
but in real life I will be in /home/onlyme - it just appears as root to... (10 Replies)
I created a new user and changed their home directory to /export/home/mydir/ I verified in the passwd file that the home directory is set to the above and that owner of that directory is the new user and yet when I log in as that user I get the following message:
No directory! Logging in with... (14 Replies)
I have a simple sandbox program which runs a command as user "nobody" in a chroot jail. It sets resource limits with setrlimit, changes the user id with setuid, changes the root dir with chroot, and then calls exec to execute the command given as command line parameters. It is of course a... (8 Replies)
I am new unix,
In the unix server we have two folders
Under each sub we have some other subfolders also.
Here my question is
I want to create sub2(including subfolder of this) as share drive to windows 2003 server.
Can... (7 Replies)
I have wrongly given a wrong home directory to a user. This dir is very critical for my production environment(Can;t afford to lose it for a single minute)
Now i want to delete that user,
Whenever i try to delete user it tries to delete its home dir.
Commnd i use:
... (9 Replies)
I wanted to change the home dir for a user, but when using smh :
SMH->Accounts for Users and Groups->Local Users->Modify User
* Required... (8 Replies)
I am trying to find the weblogic home directory whether it is installed in the Linux box. if it is existing display the weblogic home and the corresponding Java home directory else display message as that wl home does not exist. I already wrote a program but it was not working properly.... (11 Replies)
I have created an ftps server using vsftpd and it works a treat
atm to create a user/password/home dir I do these two command -
useradd test -d /mnt/data/test
also I have another dir that I use for home dirs, which is using a nfs location (vfx_ftp) and not the local... (9 Replies)