NEXTBOOT(8) BSD System Manager's Manual NEXTBOOT(8)NAME
nextboot -- specify an alternate kernel and boot flags for the next reboot
nextboot [-e variable=value] [-f] [-k kernel] [-o options]
The nextboot utility allows specifying some combination of an alternate kernel, boot flags and kernel environment for the next time the
machine is booted. Once the loader(8) loads in the new kernel information, it is deleted so in case the new kernel hangs the machine, once
it is rebooted, the machine will automatically revert to its previous configuration.
The options are as follows:
-D Invoking nextboot with this option removes an existing nextboot configuration.
This option adds the provided variable and value to the kernel environment. The value is quoted when written to the nextboot
-f This option disables the sanity checking which checks if the kernel really exists before writing the nextboot configuration.
-k kernel This option specifies a kernel directory relative to /boot to load the kernel and any modules from.
-o options This option allows the passing of kernel flags for the next boot.
/boot/nextboot.conf The configuration file that the nextboot configuration is written into.
To boot the GENERIC kernel with the nextboot command:
nextboot -k GENERIC
To enable into single user mode with the normal kernel:
nextboot -o "-s" -k kernel
To remove an existing nextboot configuration:
SEE ALSO boot(8), loader(8)HISTORY
The original nextboot manual page first appeared in FreeBSD 2.2. It used a very different interface to achieve similar results.
The current incarnation of nextboot appeared in FreeBSD 5.0.
This manual page was written by Gordon Tetlow <gordon@FreeBSD.org>.
The nextboot code is implemented in the loader(8). It is not the most thoroughly tested code. It is also my first attempt to write in
Finally, it does some evil things like writing to the file system before it has been checked. If it scrambles your file system, do not blame
BSD January 31, 2012 BSD
Check Out this Related Man Page
REBOOT(8) BSD System Manager's Manual REBOOT(8)NAME
reboot, halt, fastboot, fasthalt -- stopping and restarting the system
halt [-lnpq] [-k kernel]
reboot [-dlnpq] [-k kernel]
fasthalt [-lnpq] [-k kernel]
fastboot [-dlnpq] [-k kernel]
The halt and reboot utilities flush the file system cache to disk, send all running processes a SIGTERM (and subsequently a SIGKILL) and,
respectively, halt or restart the system. The action is logged, including entering a shutdown record into the user accounting database.
The options are as follows:
-d The system is requested to create a crash dump. This option is supported only when rebooting, and it has no effect unless a dump
device has previously been specified with dumpon(8).
Boot the specified kernel on the next system boot. If the kernel boots successfully, the default kernel will be booted on successive
boots, this is a one-shot option. If the boot fails, the system will continue attempting to boot kernel until the boot process is
interrupted and a valid kernel booted. This may change in the future.
-l The halt or reboot is not logged to the system log. This option is intended for applications such as shutdown(8), that call reboot
or halt and log this themselves.
-n The file system cache is not flushed. This option should probably not be used.
-p The system will turn off the power if it can. If the power down action fails, the system will halt or reboot normally, depending on
whether halt or reboot was called.
-q The system is halted or restarted quickly and ungracefully, and only the flushing of the file system cache is performed (if the -n
option is not specified). This option should probably not be used.
The fasthalt and fastboot utilities are nothing more than aliases for the halt and reboot utilities.
Normally, the shutdown(8) utility is used when the system needs to be halted or restarted, giving users advance warning of their impending
doom and cleanly terminating specific programs.
SEE ALSO getutxent(3), boot(8), dumpon(8), nextboot(8), savecore(8), shutdown(8), sync(8)HISTORY
A reboot utility appeared in Version 6 AT&T UNIX.
BSD October 11, 2010 BSD