LPTCONTROL(8) BSD System Manager's Manual LPTCONTROL(8)NAME
lptcontrol -- a utility for manipulating the lpt printer driver
lptcontrol -e | -i | -p | -s [-d control_device]
The lptcontrol utility is used to set either the interrupt-driven, extended, standard, or polling mode of individual lpt(4) devices. When a
printer is switched from a mode to another, this change will only take effect the next time the device is opened.
Extended mode is anything the parallel port interface can support. For an ECP/ISA parallel port, it may be FIFO+DMA or ECP.
The following command line options are supported:
-e Turn on extended mode.
-i Turn on interrupt-driven mode.
-p Turn on polled mode.
-s Turn on standard mode, i.e., turn off extended mode.
Set the mode of the printer control device specified by control_device. The default value for control_device is /dev/lpt0.ctl.
One of -e, -i, -p or -s must be specified.
/dev/lpt? printer devices
/dev/lpt?.ctl printer control devices
/sys/i386/conf/GENERIC kernel configuration file
/boot/device.hints device hints for the parallel port chipset driver, ppc(4)SEE ALSO lpt(4), ppc(4), device.hints(5)HISTORY
The lptcontrol utility first appeared in FreeBSD 1.1.5
Geoffrey M. Rehmet
The control device name should never have been an option, but should have been an optional argument. Because of this, a single argument is
treated as a device name.
BSD October 1, 2004 BSD
Check Out this Related Man Page
LPT(4) BSD Kernel Interfaces Manual LPT(4)NAME
lpt -- generic printer device driver
The current lpt driver is the port of the original lpt driver to the ppbus(4) system.
One purpose of this port was to allow parallel port sharing with other parallel devices. Secondly, inb()/outb() calls have been replaced by
ppbus function calls. lpt is now arch-independent thanks to the ppbus interface. See ppbus(4) for more info about the ppbus system.
The parallel port bus is allocated by lpt when the printer device is opened and released only when the transfer is completed: either when the
device is closed or when the entire buffer is sent in interrupt driven mode.
The driver can be configured to be either interrupt-driven, or to poll the printer. Ports that are configured to be interrupt-driven can be
switched to polled mode by using the lptcontrol(8) command.
Depending on your hardware, extended capabilities may be configured with the lptcontrol(8) command. With an ECP/ISA port, you can take
advantage of FIFO and DMA.
In order to retrieve printer info from /dev/lpt0, just apply the cat command to the device. If the printer supports IEEE1284 nibble mode and
has data to send to the host, you will get it.
/dev/lpt0 first parallel port driver
SEE ALSO ppbus(4), ppc(4), lptcontrol(8)HISTORY
This driver replaces the functionality of the lpa driver, which is now defunct.
There are lots of them, especially in cheap parallel port implementations.
It is only possible to open a lpt port when a printer is connected and on-line, making it impossible to run lptcontrol(8) when there is no
This driver could still stand a rewrite.
BSD February 14, 1999 BSD
Hello. I am really new to Unix and am trying to set up a local printer on a FreeBSD 6.2 machine. I was able to get some kind of garbage by going lptest > /dev/lpt0, but after I set up the spooler I get nothing but page after page of nothing. I checked the kernel configuration and it had the correct... (1 Reply)
I'm trying to send extended ascii characters to my HP2055 as part of PCL printer control codes. What I want to do is select a bar code font, print the bar code and reset the printer to the default font.
Selecting the bar code font works good. Printing the bar code goes almost ok too. ... (5 Replies)