KLDSTAT(8) BSD System Manager's Manual KLDSTAT(8)NAME
kldstat -- display status of dynamic kernel linker
kldstat [-q] [-v] [-i id] [-n filename]
kldstat [-q] [-m modname]
The kldstat utility displays the status of any files dynamically linked into the kernel.
The following options are available:
-v Be more verbose.
-i id Display the status of only the file with this ID.
Display the status of only the file with this filename.
-q Only check if module is loaded or compiled into the kernel.
Display the status of only the module with this modname.
The kldstat utility exits 0 on success, and >0 if an error occurs.
SEE ALSO kldstat(2), kldload(8), kldunload(8)HISTORY
The kldstat utility first appeared in FreeBSD 3.0, replacing the lkm interface.
Doug Rabson <dfr@FreeBSD.org>
BSD January 22, 2014 BSD
Check Out this Related Man Page
MODFIND(2) BSD System Calls Manual MODFIND(2)NAME
modfind -- returns the modid of a kernel module
Standard C Library (libc, -lc)
modfind(const char *modname);
The modfind() system call returns the modid of the kernel module referenced by modname.
The modfind() system call returns the modid of the kernel module referenced by file. Upon error, modfind() returns -1 and sets errno to
indicate the error.
errno is set to the following if modfind() fails:
[EFAULT] The data required for this operation could not be read from the kernel space.
[ENOENT] The file specified is not loaded in the kernel.
SEE ALSO kldfind(2), kldfirstmod(2), kldload(2), kldnext(2), kldstat(2), kldsym(2), kldunload(2), modfnext(2), modnext(2), modstat(2), kld(4),
The kld interface first appeared in FreeBSD 3.0.
BSD September 28, 2000 BSD
I know that I can load or unload kernel modules (/sbin/modload or /sbin/modunload) but how can I check what of modules are now loaded to my kernel? I heard that I can do it by /sbin/modstat but I haven't file like this in my system... Please help me.
Have a nice day (2 Replies)
I'm hoping someone can help a complete *nix amatuer here.
I've been asked to implement HSBC payment integration for a client. HSBC supply (amongst others) Linux and Windows libraries, and I've been asked to see if we can implement this on our dedicated Unix host.
Basically the system... (5 Replies)
Hi everyone.I have an Audigy2 ZS sound card. I'm not a guru so don't send me faraway)) Well my card sounds only in front channels... can't setup 5.1.
and i can't made a microphone works.
PS: A have red this Yuriy Tsibizov (AKA chibis) many time.
Here is some system info
Copyright... (0 Replies)
In Linux if you want to get rid of the PC speaker (beep!) without rebooting you can type
I'm looking for a way to remove (if possible) the BSD equivalent of the "pcspkr" module.
I scrolled quickly through GENERIC and didn't see any entries that looked conspicuously like the... (2 Replies)
The following pseudo-code should be clear to what I am trying to achieve:
if ; then
echo 'linux_enable="YES"' >> /etc/rc.conf
What is the proper syntax or operator for the test?
Thanks in advance (5 Replies)
The issue I'm having (after some effort) is that while compiz starts fine and functions (I can use the cube, expo, key bindings all good) all desktops are white. I can't see any of my windows, backgrounds, or menus. I am using FreeBSD 8 with no custom kernel options or otherwise interesting... (0 Replies)
Hi. my english is not so good. sorry.
i have some problem. My isp give me second ip from subnet. One network is working, but secong don't.
fxp0 - my network
dc0 - network isp (that working)
re0 - network isp (don't working)
i try use ng_one2many, but it's don't working
ngctl mkpeer... (0 Replies)