Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kldconfig(8) [freebsd man page]

KLDCONFIG(8)						    BSD System Manager's Manual 					      KLDCONFIG(8)

NAME
kldconfig -- display or modify the kernel module search path SYNOPSIS
kldconfig [-dfimnUv] [-S sysctlname] [path ...] kldconfig -r DESCRIPTION
The kldconfig utility displays or modifies the search path used by the kernel when loading modules using the kldload(8) utility or the kldload(2) syscall. The following options are available: -d Remove the specified paths from the module search path. -f Do not display a diagnostic message if a path specified for adding is already present in the search path, or if a path specified for removing is not present in the search path. This may be useful in startup/shutdown scripts for adding a path to a file system which is still not mounted, or in shutdown scripts for unconditionally removing a path that may have been added during startup. -i Add the specified paths to the beginning of the search path, not to the end. This option can only be used when adding paths. -m Instead of replacing the module search path with the set of paths specified, ``merge'' in the new entries. -n Do not actually change the module search path. -r Display the current search path. This option cannot be used if any paths are also specified. -S sysctlname Specify the sysctl name to use instead of the default kern.module_path. -U ``Unique-ify'' the current search path - if any of the directories is repeated one or more times, only the first occurrence remains. This option implies -m. -v Verbose output: display the new module search path. If the path has been changed, and the -v flag is specified more than once, the old path is displayed as well. FILES
/boot/kernel, /boot/modules, /modules The default module search path used by the kernel. EXIT STATUS
The kldconfig utility exits 0 on success, and >0 if an error occurs. SEE ALSO
kldload(2), kldload(8), sysctl(8) HISTORY
The kldconfig utility first appeared in FreeBSD 4.4. AUTHORS
Peter Pentchev <roam@FreeBSD.org> BSD
June 15, 2001 BSD

Check Out this Related Man Page

dlsetlibpath(3C)														  dlsetlibpath(3C)

NAME
dlsetlibpath() - set the dynamic search path used to locate shared libraries SYNOPSIS
[flag]... file... [library]... Multithread Usage This routine is thread-safe. Calls to affect all subsequent calls to and on any thread. DESCRIPTION
is one of a family of routines that give the user direct access to the dynamic linking facilities (using the option on the compiler or com- mand line). sets the dynamic search path used by and to locate shared libraries. libpath is the dynamic search path. It is a list of one or more path names separated by colons When searching for a library, the dynamic loader uses search paths in the following default order: 1. The dynamic search path specified in a call to 2. The environment variable. 3. The environment variable. 4. The embedded path of the calling module (executable program or shared library) for libraries named in calls to or For dependent libraries, the embedded path of the library that named it as a dependent is used. 5. The standard library path. 6. The current working directory. (This is only for libraries named in calls to and not their dependent libraries.) (See dld.so(5) for additional information on search paths and options that can change the order described above.) Any combination of these paths may be disabled by setting flags to one or more of the following flag values OR'ed together. If the follow- ing value is set, the dynamic loader does not search the specified location: Directories specified in the dynamic search path. Directories specified in the environment variable. Directories specified in the environment variable. Directories specified in the embedded path. Standard library directory. Current working directory. Multiple search paths can be disabled by OR'ing individual flags: flags = RTLD_FLAG_DISABLE_STD_PATH | RTLD_FLAG_DISABLE_CWD_PATH A single search path can be enabled by setting flags to the complement of the flag value that disables that search path: flags = ~RTLD_FLAG_DISABLE_DYNAMIC_PATH EXAMPLES
The following example illustrates the use of to set the dynamic search path and disable other search paths. For simplicity, error checking has been omitted. #include <dlfcn.h> int main() { void *handle; int status; int flags; /* Set dynamic search path and disable the embedded * path and the standard library directory. */ flags = RTLD_FLAG_DISABLE_EMBEDDED_PATH | RTLD_FLAG_DISABLE_STD_PATH; status = dlsetlibpath("/opt/lib:/opt/usr/lib", flags); /* Call dlopen to load a library using the dynamic * search path. */ handle = dlopen("mylib.so", RTLD_LAZY); /* Remove the dynamic search path and reenable all * disabled search paths. */ status = dlsetlibpath(NULL, 0); } RETURN VALUE
If successful, returns otherwise a non-0 value is returned. More detailed diagnostic information is available through or ERRORS
If fails, a subsequent call to returns one of the following values: Cannot allocate dynamic memory. Failed to apply relocation while resolving call to call failed on entry to call failed on exit from failed on entry to or exit from Invalid argument in call to SEE ALSO
dlopen(3C), dlopene(3C), dlgetfileinfo(3C), dlerrno(3C), dlerror(3C), dld.so(5). Texts and Tutorials: (See the option) (See manuals(5) for ordering information) dlsetlibpath(3C)
Man Page