HCCONTROL(8) BSD System Manager's Manual HCCONTROL(8)
hccontrol -- Bluetooth HCI configuration utility
hccontrol [-hN] [-n HCI_node_name] command [parameters ...]
The hccontrol utility connects to the specified Netgraph node of type HCI or the first one found if none is specified and attempts to send
the specified command to the HCI Netgraph node or to the associated Bluetooth device. The hccontrol utility will print results to the stan-
dard output and error messages to the standard error.
The options are as follows:
-h Display usage message and exit.
-N Show Bluetooth addresses as numbers. Normally hccontrol attempts to resolve Bluetooth addresses, and display them symbolically.
Connect to the specified HCI Netgraph node.
One of the supported commands (see below). The special command help can be used to obtain the list of all supported commands. To
get more information about a specific command use help command.
One or more optional space separated command parameters. Many commands require a remote device address as one of the parameters.
The remote device address can be specified as BD_ADDR or a name. If a name was specified then the hccontrol utility will attempt to
resolve the name via bt_gethostbyname(3).
The currently supported HCI commands in hccontrol are:
The currently supported node commands in hccontrol are:
The hccontrol utility exits 0 on success, and >0 if an error occurs.
bluetooth(3), netgraph(3), netgraph(4), ng_hci(4), hcseriald(8)
Maksim Yevmenkin <firstname.lastname@example.org>
Most likely. Please report if found.
February 7, 2015 BSD