Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ggatec(8) [freebsd man page]

GGATEC(8)						    BSD System Manager's Manual 						 GGATEC(8)

NAME
ggatec -- GEOM Gate network client and control utility SYNOPSIS
ggatec create [-n] [-v] [-o ro | wo | rw] [-p port] [-q queue_size] [-R rcvbuf] [-S sndbuf] [-s sectorsize] [-t timeout] [-u unit] host path ggatec rescue [-n] [-v] [-o ro | wo | rw] [-p port] [-R rcvbuf] [-S sndbuf] -u unit host path ggatec destroy [-f] -u unit ggatec list [-v] [-u unit] DESCRIPTION
The ggatec utility is a network client for GEOM Gate class. It is responsible for creation of ggate devices and forwarding I/O requests between geom_gate.ko kernel module and ggated(8) network daemon. Available commands: create Connect to given ggated(8) daemon and create a ggate provider related to the given remote file or device. rescue If ggatec process died/has been killed, you can save situation with this command, which creates new connection to the ggated(8) dae- mon and will handle pending and future requests. destroy Destroy the given ggate provider. list List ggate providers. Available options: -f Forcibly destroy ggate provider (cancels all pending requests). -n Do not use TCP_NODELAY option on TCP sockets. -o ro | wo | rw Specify permission to use when opening the file or device: read-only (ro), write-only (wo), or read-write (rw). Default is rw. -p port Port to connect to on the remote host. Default is 3080. -q queue_size Number of pending I/O requests that can be queued before they will start to be canceled. Default is 1024. -R rcvbuf Size of receive buffer to use. Default is 131072 (128kB). -S sndbuf Size of send buffer to use. Default is 131072 (128kB). -s sectorsize Sector size for ggate provider. If not specified, it is taken from device, or set to 512 bytes for files. -t timeout Number of seconds to wait before an I/O request will be canceled. 0 means no timeout. Default is 0. -u unit Unit number to use. -v Do not fork, run in foreground and print debug informations on standard output. host Remote host to connect to. path Path to a regular file or device. EXIT STATUS
Exit status is 0 on success, or 1 if the command fails. To get details about the failure, ggatec should be called with the -v option. EXAMPLES
Make use of CD-ROM device from remote host. server# cat /etc/gg.exports client RO /dev/acd0 server# ggated client# ggatec create -o ro server /dev/acd0 ggate0 client# mount_cd9660 /dev/ggate0 /cdrom SEE ALSO
geom(4), ggated(8), ggatel(8), mount_cd9660(8) AUTHORS
The ggatec utility as well as this manual page was written by Pawel Jakub Dawidek <pjd@FreeBSD.org>. BSD
April 26, 2004 BSD

Check Out this Related Man Page

G_PROVIDER(9)						   BSD Kernel Developer's Manual					     G_PROVIDER(9)

NAME
g_new_providerf, g_destroy_provider, g_error_provider -- GEOM providers management SYNOPSIS
#include <geom/geom.h> struct g_provider * g_new_providerf(struct g_geom *gp, const char *fmt, ...); void g_destroy_provider(struct g_provider *pp); void g_error_provider(struct g_provider *pp, int error); DESCRIPTION
A GEOM provider is the front gate at which a geom offers service. A provider is ``a disk-like thing which appears in /dev'' - a logical disk in other words. All providers have three main properties: name, sectorsize and size. The g_new_providerf() function creates a new provider on given geom gp. The name of the provider, which will appear as device in devfs(5), is created in a printf(3)-like way from the rest of the arguments. After creation, the caller has to set the provider's mediasize and sectorsize, as well as other desired initializations, and then call g_error_provider() to reset the provider's error, which is initially set to ENXIO. The g_destroy_provider() function destroys the given provider, cancels all related pending events and removes the corresponding devfs entry. The g_error_provider() function is used to set the provider's error value. If set to a nonzero, all I/O requests will be denied, as well as increasing its access count will not be possible (error error will be returned). RESTRICTIONS
/CONDITIONS g_new_provider(): The provider name should be unique, but this is not enforced by GEOM. If the name is not unique, one will end up with two (or more) files with the same name, which is a programmer error. The geom gp has to have a start method defined. The topology lock has to be held. g_destroy_provider(): The provider must not have consumers attached. The access count has to be 0. The topology lock has to be held. RETURN VALUES
The g_new_providerf() function returns a pointer to the newly created provider. EXAMPLES
Create an example provider, set its parameters and make it usable. struct g_provider * create_example_provider(struct g_geom *gp) { struct g_provider *pp; g_topology_lock(); pp = g_new_providerf(gp, "example_provider"); g_topology_unlock(); pp->mediasize = 65536; pp->sectorsize = 512; g_error_provider(pp, 0); return (pp); } SEE ALSO
geom(4), DECLARE_GEOM_CLASS(9), g_access(9), g_attach(9), g_bio(9), g_consumer(9), g_data(9), g_event(9), g_geom(9), g_provider_by_name(9), g_wither_geom(9) AUTHORS
This manual page was written by Pawel Jakub Dawidek <pjd@FreeBSD.org>. BSD
January 16, 2004 BSD
Man Page