EDQUOTA(8) BSD System Manager's Manual EDQUOTA(8)
edquota -- edit user quotas
edquota [-uh] [-f fspath] [-p proto-username] username ...
edquota [-u] -e fspath[:bslim[:bhlim[:islim[:ihlim]]]] [-e ...] username ...
edquota -g [-h] [-f fspath] [-p proto-groupname] groupname ...
edquota -g -e fspath[:bslim[:bhlim[:islim[:ihlim]]]] [-e ...] groupname ...
edquota -t [-u] [-f fspath]
edquota -t -g [-f fspath]
The edquota utility is a quota editor. By default, or if the -u flag is specified, one or more users may be specified on the command line.
For each user a temporary file is created with an ASCII representation of the current disk quotas for that user. The list of file systems
with user quotas is determined from /etc/fstab. An editor is invoked on the ASCII file. The editor invoked is vi(1) unless the environment
variable EDITOR specifies otherwise.
The quotas may then be modified, new quotas added, etc. Block quotas can be specified in bytes (B), kilobytes (K), megabytes (M), terabytes
(T), petabytes (P), or exabytes (E). If no units are specified, kilobytes are assumed. Inode quotas can be specified in kiloinodes (K),
megainodes (M), terainodes (T), petainodes (P), or exainodes (E). If no units are specified, the number of inodes specified are used. If
the -h flag is specified, the editor will always display the block usage and limits in a more human readable format rather than displaying
them in the historic kilobyte format. Setting a quota to zero indicates that no quota should be imposed. Setting a hard limit to one indi-
cates that no allocations should be permitted. Setting a soft limit to one with a hard limit of zero indicates that allocations should be
permitted only on a temporary basis (see -t below). The current usage information in the file is for informational purposes; only the hard
and soft limits can be changed.
On leaving the editor, edquota reads the temporary file and modifies the binary quota files to reflect the changes made.
If the -p option is specified, edquota will duplicate the quotas of the prototypical user specified for each user specified. This is the
normal mechanism used to initialize quotas for groups of users. If the user given to assign quotas to is a numerical uid range (e.g.
1000-2000), then edquota will duplicate the quotas of the prototypical user for each uid in the range specified. This allows for easy setup
of default quotas for a group of users. The uids in question do not have to be currently assigned in /etc/passwd.
If one or more -e fspath[:bslim[:bhlim[:islim[:ihlim]]]] options are specified, edquota will non-interactively set quotas defined by bslim,
bhlim, islim, and ihlim on each particular file system referenced by fspath. Here bslim is the soft limit on the number of blocks, bhlim is
the hard limit on the number of blocks, islim is the soft limit on the number of files, and ihlim is the hard limit on the number of files.
If any of the bslim, bhlim, islim, and ihlim values is omitted, it is assumed to be zero, therefore indicating that no particular quota
should be imposed. Block quotas can be specified in bytes (B), kilobytes (K), megabytes (M), terabytes (T), petabytes (P), or exabytes (E).
If no units are specified, kilobytes are assumed. Inode quotas can be specified in kiloinodes (K), megainodes (M), terainodes (T), petain-
odes (P), or exainodes (E). If no units are specified, the number of inodes specified are used.
If invoked with the -f option, edquota will read and modify quotas on the file system specified by fspath only. The fspath argument may be
either a special device or a file system mount point. The primary purpose of this option is to set the scope for the -p option, which would
overwrite quota records on every file system with quotas otherwise.
If the -g flag is specified, edquota is invoked to edit the quotas of one or more groups specified on the command line. The -p flag can be
specified in conjunction with the -g flag to specify a prototypical group to be duplicated among the listed set of groups. Similarly, -e
flag can be specified in conjunction with the -g flag to non-interactively set-up quotas on the listed set of groups.
Users are permitted to exceed their soft limits for a grace period that may be specified per file system. Once the grace period has expired,
the soft limit is enforced as a hard limit. The default grace period for a file system is specified in <ufs/ufs/quota.h>. The -t flag can
be used to change the grace period. By default, or when invoked with the -u flag, the grace period is set for all the file systems with user
quotas specified in /etc/fstab. When invoked with the -g flag the grace period is set for all the file systems with group quotas specified
in /etc/fstab. The grace period may be specified in days, hours, minutes, or seconds. Setting a grace period to zero indicates that the
default grace period should be imposed. Setting a grace period to one second indicates that no grace period should be granted. Quotas must
be turned off for the file system and then turned back on for the new grace period to take effect.
Only the super-user may edit quotas.
quota.user at the file system root with user quotas
quota.group at the file system root with group quotas
/etc/fstab to find file system names and locations
Various messages about inaccessible files; self-explanatory.
quota(1), quotactl(2), fstab(5), quotacheck(8), quotaon(8), repquota(8)
June 6, 1993 BSD