DMESG(8) BSD System Manager's Manual DMESG(8)NAME
dmesg -- display the system message buffer
dmesg [-ac] [-M core [-N system]]
The dmesg utility displays the contents of the system message buffer. If the -M option is not specified, the buffer is read from the cur-
rently running kernel via the sysctl(3) interface. Otherwise, the buffer is read from the specified core file, using the name list from the
specified kernel image (or from the default image).
The options are as follows:
-a Show all data in the message buffer. This includes any syslog records and /dev/console output.
-c Clear the kernel buffer after printing.
-M Extract values associated with the name list from the specified core.
-N If -M is also specified, extract the name list from the specified system instead of the default, which is the kernel image the system
has booted from.
/var/run/dmesg.boot usually a snapshot of the buffer contents taken soon after file systems are mounted at startup time
SEE ALSO sysctl(3), syslogd(8)HISTORY
The dmesg utility appeared in 4.0BSD.
BSD May 9, 2013 BSD
Check Out this Related Man Page
DMESG(1) General Commands Manual DMESG(1)NAME
dmesg - print or control the kernel ring buffer
dmesg [-c] [-r] [-n level] [-s bufsize]
dmesg is used to examine or control the kernel ring buffer.
The program helps users to print out their bootup messages. Instead of copying the messages by hand, the user need only:
dmesg > boot.messages
and mail the boot.messages file to whoever can debug their problem.
OPTIONS -c Clear the ring buffer contents after printing.
-r Print the raw message buffer, i.e., don't strip the log level prefixes.
Use a buffer of size bufsize to query the kernel ring buffer. This is 16392 by default. (The default kernel syslog buffer size was
4096 at first, 8192 since 1.3.54, 16384 since 2.1.113.) If you have set the kernel buffer to be larger than the default then this
option can be used to view the entire buffer.
Set the level at which logging of messages is done to the console. For example, -n 1 prevents all messages, except panic messages,
from appearing on the console. All levels of messages are still written to /proc/kmsg, so syslogd(8) can still be used to control
exactly where kernel messages appear. When the -n option is used, dmesg will not print or clear the kernel ring buffer.
When both options are used, only the last option on the command line will have an effect.
SEE ALSO syslogd(8)AVAILABILITY
The dmesg command is part of the util-linux package and is available from ftp://ftp.kernel.org/pub/linux/utils/util-linux/.
when i do a "dmesg" command, i saw many of this message appeared.
Nov 12 07:00:20 catty graph_ftp: graph_ftp ftp faild
it seems like it has some problems with my gftp application?
pls tell me what's wrong and how to solve it.
thanks alot. (1 Reply)
I have a very weard error message in my dmesg output, and I cannot find the solution in google. Does anyone know what it might be ?
Equivalently mapped reserve pool exhausted;
Overall application performance may be improved by increasing the "eqmemsize" tunable parameter (currently... (3 Replies)
i saved my system this morning, mksysb tape, and i have the message: "boot.image exceeded the size....." i have not the end because the message is disappeared.
where can i find the mksysb message in a log ?
the message is scary ?
thank you (6 Replies)
When i run dmesg, I get the following message which clearly indicates that the file system is full. Please let me know what does (1 block extent) means in the following error message?
msgcnt 1 vxfs : mesg 001: vx_nospace - /dev/vg00/lvol4 file system full (1 block extent)
Thanks (6 Replies)
My solaris server is rebooting, not sure how!!! Which log should I look in to? I checked /var/adm/messages and dmesg also. How do I check older dmesg logs? I checked lastlog and also ran the last command. Nothing useful pointing to why server rebooted.
Also when server reboots I... (4 Replies)
I have a SUN Ultra 80 running Solaris 5.8 I have a couple of applications running on it. The /var/core file seems to be filling up by 2% per day.
Could anyone pls suggest how to read contents of /var/core I have read couple of docs but seems to be too cumbersome. Please suggest something
example... (3 Replies)
I have a solaris 10 machine, lately I had a drive error issue so the dmesg command would show a screen full, now that the drive issue is resolved I want to have a fresh start for my #dmesg command output.
The root cron looks like this
The /etc/logadm.conf file has this entry
If I manually... (2 Replies)
I Have problem at my console (Ultra 24, solaris 10 x86), when i type dmesg always come out :
You have new mail.
root@console # bash
root@console # dmesg
couldn't set locale correctly
couldn't set locale correctly
So how to fix it...?
simbah (3 Replies)
I have a blade BL860c running on a C7000 chassis, in which is connected to a NetApp, so lately I am having I/O issues, and dmesg as well as syslog.log is reporting the following:
/dev/vg01/lvol2 file system file data error in dev/block 0/55892768
Page I/O error occurred while paging... (2 Replies)
I am using Ubundu.
I want to know how to run kernel functions in a separate core?
I know about Taskset and it supports only for the application.
Do anybody know any command (or) have any idea about how to do it?
Please help me
Thank you (3 Replies)
New to Suse - mainly used Solaris.
In solaris dmesg will also show you contents of messages log file but in Suse Liux it doesnt appear to.
I dont have root access to this Suse server, and wondering is there any other tool / utility that allows me to see the messages file contents like on... (1 Reply)