DEVCTL(8) BSD System Manager's Manual DEVCTL(8)
devctl -- device control utility
devctl attach device
devctl detach [-f] device
devctl disable [-f] device
devctl enable device
devctl suspend device
devctl resume device
devctl set driver [-f] device driver
The devctl utility adjusts the state of individual devices in the kernel's internal device hierarchy. Each invocation of devctl consists of
a single command followed by command-specific arguments. Each command operates on a single device specified via the device argument. The
device may be specified either as the name of an existing device or as a bus-specific address. More details on supported address formats can
be found in devctl(3).
The following commands are supported:
Force the kernel to re-probe the device. If a suitable driver is found, it is attached to the device.
detach [-f] device
Detach the device from its current device driver. If the -f flag is specified, the device driver will be detached even if the device
disable [-f] device
Disable a device. If the device is currently attached to a device driver, the device driver will be detached from the device, but
the device will retain its current name. If the -f flag is specified, the device driver will be detached even if the device is busy.
Enable a device. The device will probe and attach if a suitable device driver is found. Note that this can re-enable a device dis-
abled at boot time via a loader tunable.
Suspend a device. This may include placing the device in a reduced power state.
Resume a suspended device to a fully working state.
set driver [-f] device driver
Force the device to use a device driver named driver. If the device is already attached to a device driver and the -f flag is speci-
fied, the device will be detached from its current device driver before it is attached to the new device driver. If the device is
already attached to a device driver and the -f flag is not specified, the device will not be changed.
The devctl utility first appeared in FreeBSD 11.0.
February 5, 2015 BSD