ATH3KFW(8) BSD System Manager's Manual ATH3KFW(8)NAME
ath3kfw -- firmware download utility for Atheros AR3011 chip based Bluetooth USB devices
ath3kfw -d device_name -f firmware_file_name
The ath3kfw utility downloads the specified firmware file to the specified ugen(4) device.
This utility will only work with Atheros AR3011 chip based Bluetooth USB devices. The identification is currently based on USB vendor
ID/product ID pair. The vendor ID should be 0x0cf3 (USB_VENDOR_ATHEROS2) and the product ID should be 0x3000.
Firmware files ath3k-1.fw and ath3k-2.fw can be obtained from the linux-firmware RPM.
The options are as follows:
Specify ugen(4) device name.
Specify firmware file name for download.
-h Display usage message and exit.
The ath3kfw utility exits 0 on success, and >0 if an error occurs.
SEE ALSO libusb(3), ugen(4), devd(8)AUTHORS
Maksim Yevmenkin <firstname.lastname@example.org>
Most likely. Please report if found.
BSD November 9, 2010 BSD
Check Out this Related Man Page
USBCONFIG(8) BSD System Manager's Manual USBCONFIG(8)NAME
usbconfig -- configure the USB subsystem
usbconfig [-u unit] [-a addr] [cmds...]
usbconfig [-d [ugen]<unit>.<addr>] [cmds...]
The usbconfig utility is used to configure and dump information about the USB subsystem.
The options are as follows:
-u unit Limit device range to USB devices connected to the given USBUS unit.
-a addr Limit device range to the given USB device index. Should only be used in conjunction with the unit argument.
Limit device range to USB devices connected to the given unit and address. The unit and address coordinates may be prefixed by the
lowercased word "ugen".
-h Show help and available commands.
When called without options, usbconfig prints a list of all available USB devices.
Show information about the device on USB bus 1 at address 2:
usbconfig -u 1 -a 2 dump_info
Dump HID descriptor for device on USB bus 1 at address 2:
usbconfig -u 1 -a 2 do_request 0x81 0x06 0x2200 0 0x100
Dump string descriptor at index Z for device on USB bus 1 at address 2:
usbconfig -u 1 -a 2 dump_string Z
Dump current configuration descriptor for device on USB bus 1 at address 2:
usbconfig -u 1 -a 2 dump_curr_config_desc
Dump device descriptor for device on USB bus 1 at address 2:
usbconfig -u 1 -a 2 dump_device_desc
Program the device on USB bus 1 at address 2 to suspend, resume, power off, go into power save, or power on:
usbconfig -u 1 -a 2 suspend
usbconfig -u 1 -a 2 resume
usbconfig -u 1 -a 2 power_off
usbconfig -u 1 -a 2 power_save
usbconfig -u 1 -a 2 power_on
Display a list of available quirk names:
See usb_quirk(4) for more information on quirks.
SEE ALSO usb(4), usb_quirk(4)BSD January 6, 2010 BSD
How secure are downloads from unix.com, linux.com, etc? Not talking about off the wall individual user sites, but sites like unix.com, download.com, tucows.com? We've been inundated at work lately from viruses, and I want to make sure that for things like work related downloads, that those kind... (5 Replies)
Hi, am a new comer to the AIX side.
i had 3 specific questions.
1) what is firmware
2) how to locate the firmware running on a unix server
3) how to do firmware update(is it something i download from IBM site)
thanks everybody for taking the time and plz reply.
karthik (5 Replies)
I have an H80 that I'm migrating to 5.3 and prior to doing so it needed the firmware upgraded. I don't have copies of the old firmware that was on it since I was not the one who installed it and there were no copies to be found on the server itself. I installed the latest version and... (4 Replies)
Atmel offers a broad range of microcontrollers based on the 8051 architecture. The product line includes MCS-51® industry standard socket drop-in devices, In-System Programming capability, and small footprint 20-pin derivatives in ROMless, ROM, OTP & Flash flavors (see on-line selection table).... (2 Replies)
I have solaris X4500 with ILOM version 1.1.1. I want to update the firmware. I know that we need to use
load -source tftp://tftpserver/image file
But I do not understand what is the IP address of the tftp server that we need to type in there.
Kindly, help me with this.
Thank you (5 Replies)
how can we download the firmware form the host to the XSCF , My host is not configured with either FTP,HTTPS or proxy server. Someone told me we can do it with getflashimage but i did not find any info getflashimage man page to do it.
Any help will be appreciated. (3 Replies)
When I try to download firmware for pseries (power5 cpu), I found it seems the firmware upgrade code are same for 9117-570 and 9110-510. If they are the same current firmware level and want to upgrade to same firmware.
Am I right?
Because it descript:
This package provides new firmware for... (3 Replies)
Recently I found this (for me) really usefull tool kexec which can load a new Kernel while running one.
I tested it some times with the same kernel I was running, "rebooting" the system without powering it off at any time :D
But I need kexec basically just for live usbs. I want to start... (17 Replies)
i am currently having a Problem:
I want to restart 2 USB Bluetooth Dongles from the shell at the same time. It is very important that they are restarted nearly simultaneously, so that their clocks are starting to run at the same time.
At the moment i am using a command called... (3 Replies)
I need to upgrade my HMC from version 7.3.4 to vervion 7.3.5. The HMC has a Machine type of 7310-CR2 Xseries 335 . Where could I download the firmware for such hardware (HMC Machine type of 7310-CR2 Xseries 335 )? Please answer because I need to upgrade that HMC the HMC to bring to... (3 Replies)
Hi, I was trying to upgrade firmware for this Sun x4150 from ELOM to ILOM. I did it under GUI ELOM Manager > Maintenance > Firmware Upgrade. It then showed 'Someone is upgrading firmware' and took forever. I believe its hung due to unknown reason (wrong file used?). I poweroff and poweron the... (4 Replies)
Trying to update my M5000 firmware. trying to mount my USB to upload firmware and getting the following message.
XSCF> getflashimage -v file:///media/usb_msd/FFXCP1115.tar.gz
Free space: 97MB
Making sure mount point is clear
umount: /media/usb_msd is not mounted (according to mtab)
Trying... (2 Replies)
Hello, i'm a french IT student, not very fluent in English.
I'm trying to download firmware updates on IBM website but they asking a serial number of a server under warrenty or maintenance. But i have a personnel server for learning, training, etc... and its not under IBM warrenty or maintenance... (4 Replies)