Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

acpidb(8) [freebsd man page]

ACPIDB(8)						    BSD System Manager's Manual 						 ACPIDB(8)

NAME
acpidb -- ACPI DSDT debugger SYNOPSIS
acpidb input-file DESCRIPTION
The acpidb utility is a debugger for the ACPI DSDT. It can parse and execute various AML methods and display the result. COMMANDS
General-Purpose Commands Allocations Display list of current memory allocations Dump Address | Namepath [Byte | Word | Dword | Qword] Display ACPI objects or memory EnableAcpi Enable ACPI (hardware) mode Help Show various help screens History Display command history buffer Level DebugLevel [console] Get/Set debug level for file or console Locks Current status of internal mutexes Quit or Exit Exit the debugger Stats [Allocations | Memory | Misc | Objects | Tables] Display namespace and memory statistics Tables Display info about loaded ACPI tables Unload TableSig [Instance] Unload an ACPI table ! CommandNumber Execute command from history buffer !! Execute last command again Namespace Access Commands Event F | G Value Generate AcpiEvent (Fixed/GPE) Find Name Find ACPI name(s) with wildcards ('?' is wildcard) Method Display list of loaded control methods Namespace [Addr | Path] [Depth] Display loaded namespace tree/subtree Notify NamePath Value Send a notification Objects ObjectType Display all objects of the given type Owner OwnerId [Depth] Display loaded namespace by object owner Prefix [NamePath] Set or Get current execution prefix References Addr Find all references to object at addr Resources Get and display resources Terminate Delete namespace and all internal objects Thread Threads Loops NamePath Spawn threads to execute method(s) Control Method Execution Commands Arguments (Args) Display method arguments Breakpoint AmlOffset Set an AML execution breakpoint Call Run to next control method invocation Debug Namepath [Arguments] Single Step a control method Execute Namepath [Arguments] Execute control method Go Allow method to run to completion Information Display info about the current method Into Step into (not over) a method call List [OpcodeCount] Display method ASL statements Locals Display method local variables Results Display method result stack Set A | L # Value Set method data (Arguments/Locals) Stop Terminate control method Tree Display control method calling tree <Enter> Single step next AML opcode (over calls) File I/O Commands Close Close debug output file Open Filename Open a file for debug output Load Filename Load ACPI table from a file SEE ALSO
acpi(4), acpidump(8), iasl(8) HISTORY
The acpidb utility first appeared in the acpicatools port. It was imported for FreeBSD 5.2. AUTHORS
The acpidb utility was written by Mitsuru Iwasaki <iwasaki@FreeBSD.org> and uses Intel ACPI-CA for the backend. This manual page was written by Nate Lawson. BSD
August 7, 2003 BSD

Check Out this Related Man Page

IASL(1) 						      General Commands Manual							   IASL(1)

NAME
iasl - ACPI Source Language compiler/decompiler SYNOPSIS
iasl [options] [input file] DESCRIPTION
This manual page documents briefly the iasl command. The option list is taken from the iasl interactive help. iasl is an ASL compiler and decompiler. OPTIONS
General Output -p <prefix> Specify filename prefix for all output files (including .aml) -vi Less verbose errors and warnings for use with IDEs -vo Enable optimization comments -vr Disable remarks -vs Disable signon AML Output Files -s<a|c> Create AML in assembler or C source file (*.asm or *.c) -i<a|c> Create assembler or C include file (*.inc or *.h) -t<a|c> Create AML in assembler or C hex table (*.hex) AML Code Generation -oa Disable all optimizations (compatibility mode) -of Disable constant folding -oi Disable integer optimization to Zero/One/Ones -on Disable named reference string optimization -r<Revision> Override table header Revision (1-255) Listings -l Create mixed listing file (ASL source and AML) (*.lst) -ln Create namespace file (*.nsp) -ls Create combined source file (expanded includes) (*.src) AML Disassembler -d [file] Disassemble AML to ASL source code file (*.dsl) -dc [file] Disassemble AML and immediately compile it (Obtain DSDT from current system if no input file) -e Generate External() statements for unresolved symbols -g Get ACPI tables and write to files (*.dat) Miscellaneous -a Verify source file is entirely ASCII text (0x00-0x7F) Help -h Additional help and compiler debug options -hc Display operators allowed in constant expressions -hr Display ACPI reserved method names AUTHOR
iasl was written by Robert Moore <robert.moore@intel.com>. This manual page was written by Mattia Dongili <malattia@debian.org>, for the Debian project (but may be used by others). October 14, 2005 IASL(1)
Man Page