LOADER.4TH(8) BSD System Manager's Manual LOADER.4TH(8)
loader.4th -- loader.conf processing tools
The file that goes by the name of loader.4th is a set of commands designed to manipulate loader.conf(5) files. The default /boot/loader.rc
includes loader.4th and uses one of its commands to automatically read and process the standard loader.conf(5) files. Other commands exists
to help the user specify alternate configurations.
The commands of loader.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations,
and to loader(8) for additional commands.
Before using any of the commands provided in loader.4th, it must be included through the command:
This line is present in the default /boot/loader.rc file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
boot kernelname [...]
boot directory [...]
boot -flag ... Boot as specified by the loader.conf(5) files read.
Depending on the arguments passed, it can override boot flags and either the kernel name or the search path for
kernel and modules.
boot-conf kernelname [...]
boot-conf directory [...]
boot-conf -flag ... Works like boot described above, but instead of booting immediately, uses autoboot, so it can be stopped.
start Reads /boot/defaults/loader.conf, all other loader.conf(5) files specified in it, then loads the desired kernel
and modules (if not already loaded). After which you can use the boot or autoboot commmands or simply exit
(provided autoboot_delay is not set to NO) to boot the system. start is the command used in the default
/boot/loader.rc file (see loader(8)).
initialize Initialize the support library so commands can be used without executing start first. Like start, it reads
/boot/defaults/loader.conf and all other loader.conf(5) files specified in it (but does not load kernel or
modules). Returns a flag on the stack to indicate if any configuration files were successfully loaded.
read-conf filename Reads and processes a loader.conf(5) file. Does not proceed to boot.
enable-module module Enables the loading of module.
disable-module module Disables the loading of module.
toggle-module module Toggles the loading of module on and off.
show-module module Shows the information gathered in the loader.conf(5) files about the module module.
retry Used inside loader.conf(5) files to specify the action after a module loading fails.
ignore Used inside loader.conf(5) files to specify the action after a module loading fails.
try-include file [file ...]
Process script files if they exist. Each file, in turn, is completely read into memory, and then each of its
lines is passed to the command line interpreter. If any error is returned by the interpreter, the try-include
command aborts immediately, without reading any other files, and silently returns without error.
/boot/loader The loader(8).
/boot/loader.4th loader.4th itself.
/boot/loader.rc loader(8) bootstrapping script.
File loaded by the start command.
Load a different kernel with the standard configuration:
Read an additional configuration file and then proceed to boot:
Disable the loading of the splash screen module and bitmap and then proceed to boot:
The loader.4th set of commands first appeared in FreeBSD 3.2.
The loader.4th set of commands was written by Daniel C. Sobral <dcs@FreeBSD.org>.
A British espionage series.
November 13, 2013 BSD