LINT(7) BSD Miscellaneous Information Manual LINT(7)NAME
lint -- Lint error message list
DESCRIPTION
The following is a list of message IDs and messages produced by lint(1). It is intended to be used with -X flag of lint(1).
BSD July 5, 2000 BSD
Check Out this Related Man Page
lint(1B) SunOS/BSD Compatibility Package Commands lint(1B)NAME
lint - C program verifier
SYNOPSIS
/usr/ucb/lint [options]
DESCRIPTION
/usr/ucb/lint is the interface to the BSD Compatibility Package C program verifier. It is a script that looks for the link
/usr/ccs/bin/ucblint to the C program verifier. /usr/ccs/bin/ucblint is available only with the SPROcc package, whose default location is
/opt/SUNWspro. /usr/ucb/lint is identical to /usr/ccs/bin/ucblint, except that BSD headers are used and BSD libraries are linked before
base libraries. The /opt/SUNWspro/man/man1/lint.1 man page is available only with the SPROcc package.
OPTIONS
/usr/ucb/lint accepts the same options as /usr/ccs/bin/ucblint, with the following exceptions:
-Idir Search dir for included files whose names do not begin with a slash (/) prior to searching the usual directories. The
directories for multiple -I options are searched in the order specified. The preprocessor first searches for #include files
in the directory containing sourcefile, and then in directories named with -I options (if any), then /usr/ucbinclude, and
finally, in /usr/include.
-Ldir Add dir to the list of directories searched for libraries by /usr/ccs/bin/ucblint. This option is passed to
/usr/ccs/bin/ld. Directories specified with this option are searched before /usr/ucblib and /usr/lib.
-Y P, dir Change the default directory used for finding libraries.
EXIT STATUS
The following exit values are returned:
0 Successful completion.
>0 An error occurred.
FILES
/usr/lint/bin/ld link editor
/usr/lib/libc C library
/usr/ucbinclude BSD Compatibility directory for header files
/usr/ucblib BSD Compatibility directory for libraries
/usr/ucblib/libucb BSD Compatibility C library
/usr/lib/libsocket library containing socket routines
/usr/lib/libnsl library containing network functions
/usr/lib/libelf library containing routines to process ELF object files
/usr/lib/libaio library containing asynchronous I/O routines
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
+-----------------------------+-----------------------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+-----------------------------+-----------------------------+
|Availability |SUNWscpu |
+-----------------------------+-----------------------------+
SEE ALSO ld(1), a.out(4), attributes(5)SunOS 5.10 1 Feb 1995 lint(1B)
how can i check my code with lint? What if the code containes multiple module? The check is been done on each module separately?
What is the command to use the lint
Any relevant site???
Thanks a lot. You are doing a great job.:cool: (2 Replies)
Here is my question,
volume of records processed : 5M ( approx )
Its basically very simple operation that am trying to do and I had achieved the output that am interested. What am looking for really is to improve the performance, an optimized way to do that.
with respect to iconv, am... (3 Replies)
Hi
can anyone help me regarding the meaning of the following lint messages.
what is the use of having such lint comments in the c program.
/*lint -esym(534,cputs,fgets,cprintf) */
/*lint -efile(766,pragmas.h) */
Thanks a lot in advance. (5 Replies)
Hello All,
I have an XML file which has some errors in its tag definition according to an xsd. When i validate this xml file against an xsd, i wish to only take the errors in a file and not the complete xml. for eg.
Raman.xml has some errors induced in it.
RamanValidator.xsd holds the schema... (5 Replies)
Hi ,
I Want to apply AIX lint to my source code which all are *.cpp/*.h
>lint test.cpp
lint: 1286-332 File test.cpp must have a .c, .C or .ln extension. It is ignored.
lint: 1286-334 There are no files to process.
I am getting above error.
-Ashok (3 Replies)
I have about 20 xml files I want to use xmllint to pretty print:
xmllint --format file01.xml > pretty_file01.xml
xmllint --format file02.xml > pretty_file02.xml
etc
Is there a way I can just use "xmllint --format" on all the current xml files so I don't have to run this command 20 times?? :( (5 Replies)
Dear All,
this is my first post on this Forum, glad to be here.
I'm trying to fix an .ods file. Yes, I had a backup, but it's also corrupted.
When opening the document I get this EM:
read error
format error discovered in the file in sub-document content.xml at
2,337040(row,col).
So I... (3 Replies)
Hi All,
Need help to parse the xml file in shell script using xmllint. Below is the sample xml file.
<CARS>
<AUDI>
<Speed="45"/>
<speed="55"/>
<speed="75"/>
<speed="95"/>
</AUDI>
<BMW>
<Speed="30"/>
<speed="75"/>
<speed="120"/>
<speed="135"/>
</BMW>... (6 Replies)
This is a strange problem that I can't figure out - I run lint on my C programs to weed out unused variables. The output can be quite large, so I use sed to cut out just unused variables section. The typical command looks like this:
lint -I /usr/local/include -I./include -m hn.c
As my... (3 Replies)
Have like 50 xml files in a folder. They all have a Node named <Number>.How to display the values of <Number> with the count and filename in the folder. I am using Mac . (7 Replies)
Hi,
I'm trying to get some values from an xmlfile and want be able to process them. I'm using xmllint(v20901 on debian jessie) and this program directly outputs all results concatenated right after each other. I did not find a solution in the man page to get a different format or some output... (2 Replies)
Hi
I have an XML file which contains html urls in that node values. When i use xmllint to parse that, i am getting error (because of the sympols in the url). i have used --html option but it throws other tag errors.
Please guide me.
sample file.xml
<abc>
<bcd>
<cde>
<a>sometext</a>... (2 Replies)