Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

atf(7) [freebsd man page]

ATF(7)						       BSD Miscellaneous Information Manual						    ATF(7)

NAME
ATF -- introduction to the Automated Testing Framework DESCRIPTION
The Automated Testing Framework (ATF) is a collection of libraries to implement test programs in a variety of languages. These libraries all offer similar functionality and any test program written with them exposes a consistent user interface. Test programs using the ATF libraries rely on a separate runtime engine to execute them in a deterministic fashion. The runtime engine iso- lates the test programs from the rest of the system and ensures some common side-effects are cleaned up. The runtime engine is also respon- sible for gathering the results of all tests and composing reports. The current runtime of choice is Kyua, described in kyua(1). If your operating systems distributes ATF, it should also provide an introductory tests(7) manual page. You are encouraged to read it now. The rest of this manual page serves as a cross-reference to all the other documentation shipped with ATF. Language bindings atf-c(3) C programming interface. atf-c++(3) C++ programming interface. atf-sh(3) sh(1) programming interface. Miscellaneous pages atf-test-case(4) Generic description of test cases, independent of the language they are implemented in. atf-test-program(1) Common interface provided by the test programs written using the ATF libraries. SEE ALSO
kyua(1), tests(7) HISTORY
ATF started as a Google Summer of Code 2007 project mentored by The NetBSD Foundation. Its original goal was to provide a testing framework for the NetBSD operating system, but it grew as an independent project because the framework itself did not need to be tied to a specific operating system. Originally, ATF shipped the collection of libraries described in this manual page as well as a runtime engine. The runtime engine has since been replaced by Kyua and the old tools were removed in 0.20, which shipped in early 2014. As of late 2014, both FreeBSD and NetBSD ship ATF in their base systems and provide extensive test suites based on it. For more details on historical changes, refer to: /usr/share/doc/atf/NEWS AUTHORS
For more details on the people that made ATF possible, refer to: /usr/share/doc/atf/AUTHORS BSD
September 14, 2014 BSD

Check Out this Related Man Page

ATF-CONFIG(1)						    BSD General Commands Manual 					     ATF-CONFIG(1)

NAME
atf-config -- queries static configuration information of ATF SYNOPSIS
atf-config [-t] [var1 [.. varN]] atf-config -h DESCRIPTION
atf-config is a utility that queries static configuration information of ATF. Static configuration refers to all those values for settings that were built into the ATF binaries at build time. In the first synopsis form, atf-config will print variable-value pairs for all built-in static variables if no variable names are provided as arguments. If any is provided, it will only print the variable-value pairs for those variables. The output of the utility does not use the '=' symbol to separate the variable name from its corresponding value in an attempt to avoid sourcing the output in shell scripts or Make- files. If you need to do that, the -t flag allows you to query the value of individual variables without any surrounding text. In the second synopsis form, atf-config will print information about all supported options and their purpose. The following options are available: -h Shows a short summary of all available options and their purpose. -t Changes the output of the utility to show the variable values, one per line, without the variable names. Static configuration variables The following list describes all the variables that are part of ATF's static configuration: atf_arch The architecture name detected by ATF. This is derived from atf_machine because it is a subset of it. Given that this name might be misdetected, it is provided to the user as a configuration variable so that he can fix its value tempo- rarily until a real fix is incorporated into mainstream sources. atf_build_cc The C compiler used by the ATF checks that provide build-time tests. atf_build_cflags The C compiler flags used by the ATF checks that provide build-time tests. atf_build_cpp The C/C++ preprocessor used by the ATF checks that provide build-time tests. atf_build_cppflags The C/C++ preprocessor flags used by the ATF checks that provide build-time tests. atf_build_cxx The C++ compiler used by the ATF checks that provide build-time tests. atf_build_cxxflags The C++ compiler flags used by the ATF checks that provide build-time tests. atf_confdir The path to the directory that contains the system-wide configuration files for ATF. atf_includedir The path to the directory that contains the ATF header files. atf_libdir The path to the directory that contains the ATF libraries. atf_libexecdir The path to the directory that contains the auxiliary utilities of ATF, used internally by the public tools. atf_machine The machine type name detected by ATF. This should not be tunable but is provided for symmetry with atf_arch. atf_pkgdatadir The path to the directory that contains the files that form the ATF's shell-scripting library. atf_shell The path to the shell interpreter that will be used by ATF. atf_workdir The path to the temporary directory that the utilities and the test programs will use to store temporary files in. ENVIRONMENT
Every variable that is part of the static configuration can be overridden at run-time by defining an environment variable. This environment variable has the exact same name as the one shown by atf-config except that the name is all composed of uppercase letters. In general, empty values in the environment will be ignored unless otherwise noted below. The recognized environment variables are: ATF_ARCH Overrides the built-in value of atf_arch. ATF_BUILD_CC Overrides the built-in value of atf_build_cc. ATF_BUILD_CFLAGS Overrides the built-in value of atf_build_cflags. Empty values are allowed. ATF_BUILD_CPP Overrides the built-in value of atf_build_cpp. ATF_BUILD_CPPFLAGS Overrides the built-in value of atf_build_cppflags. Empty values are allowed. ATF_BUILD_CXX Overrides the built-in value of atf_build_cxx. ATF_BUILD_CXXFLAGS Overrides the built-in value of atf_build_cxxflags. Empty values are allowed. ATF_CONFDIR Overrides the built-in value of atf_confdir. ATF_INCLUDEDIR Overrides the built-in value of atf_includedir. ATF_LIBDIR Overrides the built-in value of atf_libdir. ATF_LIBEXECDIR Overrides the built-in value of atf_libexecdir. ATF_MACHINE Overrides the built-in value of atf_machine. ATF_PKGDATADIR Overrides the built-in value of atf_pkgdatadir. ATF_SHELL Overrides the built-in value of atf_shell. ATF_WORKDIR Overrides the built-in value of atf_workdir. SEE ALSO
atf(7) BSD
March 14, 2009 BSD
Man Page