DEVFS.RULES(5) BSD File Formats Manual DEVFS.RULES(5)
devfs.rules -- devfs configuration information
The devfs.rules file provides an easy way to create and apply devfs(8) rules, even for devices that are not available at boot.
For devices available at boot, see devfs.conf(5).
The format of this file is simple. Empty lines and lines beginning with a hash sign ('#') are ignored. A line between brackets denotes the
start of a ruleset. In the brackets should be the name of the ruleset and its number, separated by an equal sign.
Other lines are rule specifications as documented in devfs(8), in the section Rule Specification. These lines are prepended with ``rule''
and are passed to devfs(8) by the startup scripts of the system. It is important to put path elements that contain glob(3) special charac-
ters between quotes.
Rulesets should have a unique name and number.
All rules that follow a ruleset declaration belong to that ruleset, until a new ruleset is started.
One custom ruleset has to be enabled in /etc/rc.conf, otherwise it will not be applied to the /dev file system by the default system startup
process. For example, to enable a ``localrules'' ruleset for the /dev file system, you would have to use something like this in your rc.conf
/etc/defaults/devfs.rules Default devfs.rules configuration file.
/etc/devfs.rules Local devfs.rules configuration file. Rulesets in here override those in /etc/defaults/devfs.rules with the
same ruleset number, otherwise the two files are effectively merged.
To make all the partitions of da(4) devices readable and writable by their owner and the ``usb'' group, the following rule may be used:
add path 'da*s*' mode 0660 group usb
The first line declares and starts a new ruleset, with the name localrules and the number 10.
To give usbconfig(8) and libusb(3) enabled applications permission to all usb devices for their owner and the ``usb'' group, a similar rule
may be used:
add path 'usb/*' mode 0660 group usb
glob(3), devfs(5), devfs.conf(5), devfs(8)
This manual page was written by Roland Smith <firstname.lastname@example.org>.
February 21, 2010 BSD