URNDIS(4) BSD Kernel Interfaces Manual URNDIS(4)NAME
urndis -- USB Remote NDIS Ethernet device
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The urndis driver provides Ethernet access over Remote NDIS (RNDIS), allowing mobile devices such as phones and tablets to provide network
access. It is often referred to as USB tethering, and in most cases must be explicitly enabled on the device.
urndis should work with any USB RNDIS devices, such as those commonly found on Android devices. It does not support different media types or
options. For more information on configuring this device, see ifconfig(8).
The urndis driver supports the "tethering" functionality of many Android devices.
SEE ALSO arp(4), cdce(4), ipheth(4), netintro(4), usb(4), ifconfig(8)HISTORY
The urndis device driver first appeared in OpenBSD 4.7. The first FreeBSD release to include it was FreeBSD 9.3.
The urndis driver was written by Jonathan Armani <firstname.lastname@example.org>, Michael Knudsen <email@example.com>, and Fabien Romano
<firstname.lastname@example.org>. It was ported to FreeBSD by Hans Petter Selasky <hps@FreeBSD.org>.
BSD October 2, 2014 BSD
Check Out this Related Man Page
SMSC(4) BSD Kernel Interfaces Manual SMSC(4)NAME
smsc -- USB SMSC LAN9xxx Fast Ethernet driver
To load the driver as a module at boot time, place the following line in loader.conf(5):
Alternatively, to compile this driver into the kernel, place the following lines in your kernel configuration file:
The smsc device driver provides support for USB Fast Ethernet adapters based on the SMSC LAN9xxx chipsets.
For more information on configuring this device, see ifconfig(8).
The following devices are supported by the smsc driver:
o SMSC LAN9500, LAN9500A, LAN9505 and LAN9505A based Ethernet adapters
o SMSC LAN89530, LAN9530 and LAN9730 based Ethernet adapters
o SMSC LAN951x Ethernet adapters with integrated USB hub
SEE ALSO arp(4), intro(4), miibus(4), netintro(4), usb(4), ifconfig(8)HISTORY
The smsc device driver first appeared in FreeBSD 10.0.
The smsc driver was written by Ben Gray <bgray@FreeBSD.org>.
BSD September 26, 2014 BSD
Please help. I have downloaded the openbsd 2.9 snapshot from ftp.openbsd.org. the following files were downloaded from the snapshot dir. ( the whole dir. was downloaded ) base29,bsd,bsd.rd,cdrom29.fs,cksum,comp29,etc29,all three floppy images,game29,index,install.ata,install.chs... (11 Replies)
Newbie to 'nix here. I ran slackware 7.0 for a few months, but am more interested in the BSD flavors. The two I've been considering for my new box are FreeBSD and OpenBSD. I'm in the process of researching the two, but wanted to know if anyone in the crowd could give some advice. Is... (4 Replies)
This feels really silly, but i just dont get it..
I just installed openbsd on one of my machines, usually
i dont have this problem, but now, when i try to use ifconfig
to give myself an ipadress, i get this errormsg:
OpenAMD# ifconfig ep0 192.168.51.16
ifconfig: SIOCGIFFLAGS: Device not... (5 Replies)
hi, i am on a quest to access and even mount if possible a drive on os x. there is no driver for the device, but it lists fine in the system profiler. can i access its location from the terminal? how? here is what i get on the system profiler:
Speed: Up to 480 Mb/sec
... (3 Replies)
Let's find out about users of Android. I'm becoming a big Android follower. You?
After a lot of research, I am thinking to by the Samsung Galaxy S as soon as it updates to Android 2.2.
I'm also closely following the release of the Samsung Galaxy Tab! (14 Replies)
I'm about to make the switch over to Android OS for my mobile phone. I'm thinking my first Android phone might be something like a Samsung Galaxy S or an HTC Desire HD, or I might wait for one of the new Android tablets coming out later this year (like the Samsung 7" tablet on Android).
Was... (10 Replies)
I'm trying to get a MacBook Air (MBA) running 10.6.5 to recognize a Samsung Galaxy S (Android 2.2) vis the USB interface for simple file transfers back and forth. Nothing works so far. I've tried many things! :wall:
I noticed when I connect my phone to the MBA, there is a message in system.log... (2 Replies)
I don't know if this is the right Forum for my question, but since Android technically is a UNIX-based system...
I have a rooted Android and a Terminal emulator and bash installed.
I wanted to write a little script for my android that activates GPS, gets the location and sends... (3 Replies)
Hi, I'm and Android developer using Mac OSX 10.7. I use Dsixda's Android Kitchen to develop my roms. I had it working fine on 10.6.8 and it still worked flawlessly when updating to 10.7. I installed Macports, and installed some packages, and then tried to run the Android Kitchen. I CD'd to the... (2 Replies)
Hi, I'm and Android developer using Mac OSX 10.7. I use Dsixda's Android Kitchen to develop my roms. I had it working fine on 10.6.8 and it still worked flawlessly when updating to 10.7. I installed Macports, and installed some packages, and then tried to run the Android Kitchen. I CD'd to the... (3 Replies)
I want to copy my .mp4 files from a file of my mobile to my pc using the programm adb (Android Development Bridge).
./copyfiletopc /sdcard/Playtube ~/musik/PlayTube \.mp4
# $1 = from dir
# $2 = to dir
# $3 = search
# adb is the... (2 Replies)
I am thinking of developing an app' for Android mobile devices...
Two questions here:-
1) Does anyone _develop_ for the Android _mobile_ platform?
If so do you use OSX 10.7.5 or greater as your _development_platform_?
2) I know ********* is gonna say that the Android terminal/shell is... (13 Replies)
I have a program that logs serial port data. In order to do so it requires the full device name in linux (e.g. /dev/ttyUSB0) and a baudrate.
Does anyone know how I can find out the device name in the terminal? I am trying to port this application to Android and cant figure it out.
... (22 Replies)