ULED(4) BSD Kernel Interfaces Manual ULED(4)NAME
uled -- USB LED driver
SYNOPSIS
To compile this driver into the kernel, place the following lines into your kernel configuration file:
device uled
device usb
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
uled_load="YES"
DESCRIPTION
The uled driver provides support for the Dream Cheeky WebMail Notifier device.
Subsequently, the /dev/uled0 device can be used by userland applications.
IOCTLS
The following ioctl(2) commands can be performed on /dev/uled0, which are defined in <dev/usb/uled_ioctl.h>:
ULED_GET_COLOR
The command returns LED colors with values for RGB. This ioctl(2) takes the following structure:
struct uled_color {
uint8_t red;
uint8_t green;
uint8_t blue;
};
ULED_SET_COLOR
The command sets LED colors with values for RGB. It uses the same structure as above.
FILES
/dev/uled0 blocking device node
SEE ALSO ohci(4), uhci(4), usb(4)AUTHORS
The uled driver was written by Kevin Lo <kevlo@FreeBSD.org>.
BSD September 5, 2014 BSD
Check Out this Related Man Page
UMS(4) BSD Kernel Interfaces Manual UMS(4)NAME
ums -- USB mouse driver
SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device ums
device uhci
device ohci
device usb
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
ums_load="YES"
DESCRIPTION
The ums driver provides support for mice that attach to the USB port. Supported are mice with any number of buttons and mice with a wheel.
The /dev/ums0 device presents the mouse as a sysmouse or mousesystems type device. See moused(8) for an explanation of these mouse types.
FILES
/dev/ums0 blocking device node
EXAMPLES
Use the first USB mouse on the system as your console mouse:
moused -p /dev/ums0 -t auto
To be able to use the USB mouse under X, change the "Pointer" section in xorg.conf to the following:
Device /dev/ums0
Protocol Auto
If you want to be able to use the mouse in both virtual consoles as well as in X change it to:
Device /dev/sysmouse
Protocol Auto
SEE ALSO ohci(4), sysmouse(4), uhci(4), usb(4), xorg.conf(5) (ports/x11/xorg), moused(8)AUTHORS
The ums driver was written by Lennart Augustsson <augustss@cs.chalmers.se> for NetBSD and was adopted for FreeBSD by MAEKAWA Masahide
<bishop@rr.iij4u.or.jp>.
This manual page was written by Nick Hibma <n_hibma@FreeBSD.org> with input from Kazutaka YOKOTA <yokota@zodiac.mech.utsunomiya-u.ac.jp>.
BSD November 27, 2006 BSD
Dear linuxers,
I have a usb mess storage device.
My OS is rh as3 update2.
Each time I use the command
mount -t vfat /dev/sda1 /mnt/usb
I got the error "the device is not a valid block device".
I found from google that I should install the module sd_mod
I use the command
insmod sd_mod... (2 Replies)
Hi
can anybody help me when i boot up my machine the LED runs until it gets to 406coch6 and it simply stops their
noting appears on the screen...?
Is their a website that lists all the codes and their meaning
Thanks
Liam (2 Replies)
hi all!
im making a program to update a file on a usb device. but the mount point is different from computer to computer depending on drives, now im updating the changes.lzm on a usb system based on slax. called backtrack, so thers a folder on the root of the memory stick called BT3. and i know... (3 Replies)
hi, first of all, i would really like to know how to find out where my usb is in the system. if i "cd to /dev/usb i have a hub0 to hub4 and hid0 -- hid5 .. how do i know where my usb is?
and i guess once i find out which one my usb is at, i can do something like "mount /dev/usb/xxx /tmp" ... (5 Replies)
Hi, I'm trying to mount a usb drive but the path /dev/sda1 does not show up under /dev when I plug in the usb device.
In fact I see no differences under /dev before and after I plugin my usb drive.
Any ideas why the system is not recognizing the usb drive and how to fix?
This is on a... (3 Replies)
hi guys,
i have 2 hp-ux servers at my office with flashing system LED.
am very new to hp-ux...no much of access directly to the server.
how can i check for faults relating to this flashing of this system LED?
the DC is pretty far from my office...all i have is an ssh access into the server.... (4 Replies)
hi, I was wondering if there's a way to safely disconnect a usb device from computer, I ask this because in windows when you disconnect a usb pen with the safe removal, the pen light then turns off, while I tried removing the pen with solaris and the light was still on ? (2 Replies)
Hi,
Am working on an embedded device with a camera and I would want to send the video data it streams to a usb device connected to it. Am using the c language and of course Linux (Fedora).
Any help and suggestions are most welcomed.
Thanks in advance.:) (1 Reply)
I got the system couple of days back from one of my friend. Last night I turned it on and I noticed that maintenance LED is on. At the same time I added an LCD monitor via VGA and nothing was showing on the screen. Though the system does not have any HDD So not sure if system will even show a BIOS... (3 Replies)
Hi,
i am developing an application on an ARM 7 architatcure with a small Linux.
i want to run tar on a usb device (~10 Mb) but it runs realy slow. the command only takes 1% of cpu usage.
is there a way to improve the tar command or is the USB-Connection the bottleneck here? (4 Replies)
I would probably set all my rubber points here to get some real help for creating a boot device on a usb-stick. There is no CD-drive on this machine, thats why I need to use a usb-stick. And scrumming in a CD-drive to fuddle around in the fstab or something like that is out of reach.
My wisdom so... (9 Replies)
I've searched a number of sites but thought I'd post it here. I'm want to a detect certain usb device (external camera) that is actively being used by an app on a mac.
My search has led me through looking at the system events log to see if there is a ProductID indicator logged. The device is... (2 Replies)