UCYCOM(4) BSD Kernel Interfaces Manual UCYCOM(4)NAME
ucycom -- device driver for Cypress CY7C63743 and CY7C64013 USB to RS232 bridges
SYNOPSIS
To compile this driver into the kernel, place the following line in your kernel configuration file:
device usb
device ucom
device ucycom
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
ucycom_load="YES"
DESCRIPTION
The ucycom driver provides support for the Cypress CY7C63743 and CY7C64013 bridge chips. These chips were designed to provide a low-cost
transition path to USB for existing RS232 devices, and have fairly limited capabilities.
The ucycom driver behaves like a tty(4).
HARDWARE
The ucycom driver currently supports the following devices which incorporate Cypress USB to RS232 bridge chips:
o DeLorme Earthmate USB GPS receiver
SEE ALSO tty(4), usb(4)HISTORY
The ucycom driver first appeared in FreeBSD 5.3.
AUTHORS
The ucycom driver and this manual page were written by Dag-Erling Smorgrav <des@FreeBSD.org>.
BSD November 20, 2011 BSD
Check Out this Related Man Page
UARK(4) BSD Kernel Interfaces Manual UARK(4)NAME
uark -- Arkmicro Technologies ARK3116 based USB serial adapter
SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device uark
device ucom
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
uark_load="YES"
DESCRIPTION
The uark driver supports Arkmicro Technologies ARK3116 based serial adapters.
HARDWARE
The uark driver supports the following adapters:
o HL USB-RS232
o HugePine USB-UART
o KQ-U8A Data Cable
o Skymaster USB to RS232
SEE ALSO tty(4), ucom(4), usb(4)HISTORY
The uark device driver first appeared in OpenBSD 4.0. The first FreeBSD release to include it was FreeBSD 7.0.
AUTHORS
The uark driver was written by Jonathan Gray <jsg@openbsd.org>.
CAVEATS
Setting hardware flow control is not currently supported. It is not yet known how to ask the hardware to send a break.
Arkmicro Technologies do not reply to requests of documentation for their products.
BSD November 15, 2006 BSD
Need help for RS232 communication with switches in order to optimise the data traffic. How to manipulate different flags in termios struct to do the same? (1 Reply)
Hello friends,
I am building one driver related to wifi. When I am looking its hex dump, I can see that it is including a path to one particular file of kernel headers. It is as under.
6C 75 65 2E 0A 00 00 00 25 64 2E 25 64 2E 25 64 lue.....%d.%d.%d
2D 25 73 00 00 00 00 00 42 45... (4 Replies)
I searched the forums for RS232 issues, but all of the results don't help me solving my problem, so I had to open new thread.
This is the problem:
I have PIC16F877A micro-controller and I'm programming it with Easypic5(the PIC programming device(board) from MikroElektronika) and I want to... (1 Reply)
I'm a beginner to the Linux programming and trying my hands on some device driver examples while practising. The below code (a trimmed down version of tiny_tty.c from ldd3 book) loads perfectly using insmod and I'm able to see it in /proc/tty/drivers , /proc/modules and device nodes are getting... (1 Reply)