U3G(4) BSD Kernel Interfaces Manual U3G(4)
u3g -- USB support for 3G datacards
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
If neither of the above is done, the driver will automatically be loaded by devd(8) when the device is connected.
The u3g driver provides support for the multiple USB-to-serial interfaces exposed by many 3G USB/PCCard modems.
The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
The u3g driver supports the following adapters:
o Option GT 3G Fusion, GT Fusion Quad, etc. (only 3G part, not WLAN)
o Option GT 3G, GT 3G Quad, etc.
o Vodafone Mobile Connect Card 3G
o Vodafone Mobile Broadband K3772-Z
o Qualcomm Inc. CDMA MSM
o Huawei B190, E180v, E220 ('<Huawei Mobile>')
o Novatel U740, MC950D, X950D, etc.
o Sierra MC875U, MC8775U, etc.
(See /sys/dev/usb/serial/u3g.c for the complete list of supported cards for each vendor mentioned above.)
The supported 3G cards provide the necessary modem port for ppp, or mpd connections as well as extra ports (depending on the specific device)
to provide other functions (additional command port, diagnostic port, SIM toolkit port).
In some of these devices a mass storage device supported by the umass(4) driver is present which contains Windows and Mac OS X drivers. The
device starts up in disk mode (TruInstall, ZeroCD, etc.) and requires additional commands to switch it to modem mode. If your device is not
switching automatically, please try to add quirks. See usbconfig(8) and usb_quirk(4).
tty(4), ucom(4), usb(4), usb_quirk(4), devd(8), usbconfig(8)
The u3g driver appeared in FreeBSD 7.2, is based on the uark(4) driver, and written by Andrea Guzzo <email@example.com> in September 2008.
The u3g driver was written by Andrea Guzzo <firstname.lastname@example.org> and Nick Hibma <n_hibma@FreeBSD.org>. Hardware for testing was provided by
AnyWi Technologies, Leiden, NL.
The automatic mode switch from disk mode to modem mode does not work unless the driver is either built into the kernel or loaded before the
device is connected.
November 26, 2013 BSD