SND_MAESTRO3(4) BSD Kernel Interfaces Manual SND_MAESTRO3(4)
snd_maestro3 -- ESS Maestro3/Allegro-1 bridge device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The snd_maestro3 driver provides support for the ESS Maestro3 and Allegro-1 sound chips under the PCM framework. These chips are mostly
found in laptop computers and feature an AC97 mixer, a multi-channel sample rate converter that can mix up to four digital audio streams in
hardware, recording support, and external volume control buttons.
The firmware for the sound processor is licensed under the GNU Public License, and thus this driver is not included in the default GENERIC
The snd_maestro3 driver supports the following audio devices:
o ESS Technology Allegro-1
o ESS Technology Maestro3
The hardware volume control buttons can be connected to two different pin sets (GPIO or GD) on the chip, depending on the manufacturer. The
driver has no way of determining this configuration, so a hint may be used to override the default guess. The default setting for hardware
volume control assumes that GD pins are wired to control the hardware volume. For systems that have the GPIO pins wired to the hardware vol-
ume control buttons, add the line ``hint.pcm.0.hwvol_config="0"'' to the file /boot/device.hints to override the default setting.
The snd_maestro3 driver first appeared in FreeBSD 4.3.
Scott Long <scottl@FreeBSD.org>
Darrel Anderson <email@example.com>
December 15, 2005 BSD