Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pts(4) [freebsd man page]

PTS(4)							   BSD Kernel Interfaces Manual 						    PTS(4)

NAME
pts -- pseudo-terminal driver DESCRIPTION
The pts driver provides support for a device-pair termed a pseudo-terminal. A pseudo-terminal is a pair of character devices, a master device and a slave device. The slave device provides to a process an interface identical to that described in tty(4). However, whereas all other devices which provide the interface described in tty(4) have a hardware device of some sort behind them, the slave device has, instead, another process manipulating it through the master half of the pseudo-terminal. That is, anything written on the master device is given to the slave device as input and anything written on the slave device is presented as input on the master device. The following ioctl(2) calls apply only to pseudo-terminals: TIOCPKT Enable/disable packet mode. Packet mode is enabled by specifying (by reference) a nonzero parameter and disabled by specifying (by reference) a zero parameter. When applied to the master side of a pseudo-terminal, each subsequent read(2) from the termi- nal will return data written on the slave part of the pseudo-terminal preceded by a zero byte (symbolically defined as TIOCPKT_DATA), or a single byte reflecting control status information. In the latter case, the byte is an inclusive-or of zero or more of the bits: TIOCPKT_FLUSHREAD whenever the read queue for the terminal is flushed. TIOCPKT_FLUSHWRITE whenever the write queue for the terminal is flushed. TIOCPKT_STOP whenever output to the terminal is stopped a la '^S'. TIOCPKT_START whenever output to the terminal is restarted. TIOCPKT_DOSTOP whenever VSTOP is '^S' and VSTART is '^Q'. TIOCPKT_NOSTOP whenever the start and stop characters are not '^S/^Q'. While this mode is in use, the presence of control status information to be read from the master side may be detected by a select(2) for exceptional conditions. This mode is used by rlogin(1) and rlogind(8) to implement a remote-echoed, locally '^S/^Q' flow-controlled remote login with proper back-flushing of output; it can be used by other similar programs. TIOCGPTN Obtain device unit number, which can be used to generate the filename of the pseudo-terminal slave device. This ioctl(2) should not be used directly. Instead, the ptsname(3) function should be used. TIOCPTMASTER Determine whether the file descriptor is pointing to a pseudo-terminal master device. This ioctl(2) should not be used directly. It is used to implement routines like grantpt(3). FILES
The files used by this pseudo-terminals implementation are: /dev/pts/[num] Pseudo-terminal slave devices. DIAGNOSTICS
None. SEE ALSO
posix_openpt(2), grantpt(3), ptsname(3), pty(4), tty(4) HISTORY
A pseudo-terminal driver appeared in 4.2BSD. In FreeBSD 8.0, it was replaced with the pts driver. BSD
August 20, 2008 BSD

Check Out this Related Man Page

pty(4)							     Kernel Interfaces Manual							    pty(4)

Name
       pty - pseudoterminal driver

Syntax
       pseudo-device pty[n]

Description
       The  driver  provides  support for a device-pair termed a pseudoterminal.  A pseudoterminal is a pair of character devices, a master device
       and a slave device.  The slave device provides processes with an interface identical to	that  described  in  However,  whereas	all  other
       devices	that  provide  the  interface described in have a hardware device of some sort behind them, the slave device has, instead, another
       process manipulating it through the master half of the pseudoterminal.  That is, anything written on the master	device	is  given  to  the
       slave  device as input and anything written on the slave device is presented as input on the master device.  The slave device can be opened
       multiple times, while the master half can be opened only once.

       If no optional n value is given defining the number of pseudoterminal pairs to be configured, 16 pseudoterminal pairs are configured.   All
       pseudoterminal  lines should have a corresponding entry in the /etc/ttys file.  This must be done to insure that logins that use pseudoter-
       minals will be tracked in the utmp and wtmp files.

       The following calls apply only to pseudoterminals:

       TIOCSTOP
	      Stops output to a terminal (for example, like typing CTRL/S).  Takes no parameter.

       TIOCSTART
	      Restarts output (stopped by TIOCSTOP or by typing CTRL/S).  Takes no parameter.

       TIOCPKT
	      Enable/disable packet mode.  Packet mode is enabled by specifying (by reference) a nonzero parameter and disabled by specifying  (by
	      reference)  a  zero  parameter.	When applied to the master side of a pseudoterminal, each subsequent from the terminal will return
	      data written on the slave part of the pseudoterminal preceded by a zero byte (symbolically defined as  TIOCPKT_DATA),  or  a  single
	      byte reflecting control status information.  In the latter case, the byte is an inclusive-or of zero or more of the bits:

	      TIOCPKT_FLUSHREAD
		     whenever the read queue for the terminal is flushed.

	      TIOCPKT_FLUSHWRITE
		     whenever the write queue for the terminal is flushed.

	      TIOCPKT_STOP
		     whenever output to the terminal is stopped by typing CTRL/S.

	      TIOCPKT_START
		     whenever output to the terminal is restarted.

	      TIOCPKT_DOSTOP
		     whenever the stop character is CTRL/S and the start character is CTRL/Q.

	      TIOCPKT_NOSTOP
		     whenever the start and stop characters are not CTRL/S and/or CTRL/Q.

	      This  mode  is used by and to implement a remote-echoed, locally flow-controlled (using CTRL/S or CTRL/Q, or both) remote login with
	      proper back-flushing of output.  It can be used by other similar programs.

       TIOCREMOTE
	      A mode for the master half of a pseudoterminal, independent of TIOCPKT.  This mode causes input to the  pseudoterminal  to  be  flow
	      controlled  and  not  input edited (regardless of the terminal mode).  Each write to the control terminal produces a record boundary
	      for the process reading the terminal.  In normal usage, a write of data is like the data typed as a line on the terminal; a write of
	      0  bytes	is  like  typing  an end-of-file character.  TIOCREMOTE can be used when doing remote line editing in a window manager, or
	      whenever flow-controlled input is required.

       TIOCMASTER
	      Allows the master to have complete control over the pseudoterminal and causes the slave side to sleep until the master  relinquishes
	      control.	This is useful in preventing changes on the pseudoterminal from going undetected and being reset by the master.

Files
       (master pseudoterminals)

       (slave pseudoterminals)

See Also
       tty(4), MAKEDEV(8)

																	    pty(4)
Man Page

Featured Tech Videos