PADLOCK(4) BSD Kernel Interfaces Manual PADLOCK(4)NAME
padlock -- driver for the cryptographic functions and RNG in VIA C3, C7 and Eden processors
SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device crypto
device padlock
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
padlock_load="YES"
DESCRIPTION
The C3 and Eden processor series from VIA include hardware acceleration for AES. The C7 series includes hardware acceleration for AES, SHA1,
SHA256 and RSA. All of the above processor series include a hardware random number generator.
The padlock driver registers itself to accelerate AES operations and, if available, HMAC/SHA1 and HMAC/SHA256 for crypto(4). It also regis-
ters itself to accelerate other HMAC algorithms, although there is no hardware acceleration for those algorithms. This is only needed so
padlock can work with ipsec(4).
The hardware random number generator supplies data for the kernel random(4) subsystem.
SEE ALSO crypt(3), crypto(4), intro(4), ipsec(4), random(4), crypto(9)HISTORY
The padlock driver first appeared in OpenBSD. The first FreeBSD release to include it was FreeBSD 6.0.
AUTHORS
The padlock driver with AES encryption support was written by Jason Wright <jason@OpenBSD.org>. It was ported to FreeBSD and then extended
to support SHA1 and SHA256 by Pawel Jakub Dawidek <pjd@FreeBSD.org>. This manual page was written by Christian Brueffer
<brueffer@FreeBSD.org>.
BSD February 8, 2010 BSD
Check Out this Related Man Page
HIFN(4) BSD Kernel Interfaces Manual HIFN(4)NAME
hifn -- Hifn 7751/7951/7811/7955/7956 crypto accelerator
SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device crypto
device cryptodev
device hifn
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
hifn_load="YES"
DESCRIPTION
The hifn driver supports various cards containing the Hifn 7751, 7951, 7811, 7955, and 7956 chipsets.
The hifn driver registers itself to accelerate DES, Triple-DES, AES (7955 and 7956 only), ARC4, MD5, MD5-HMAC, SHA1, and SHA1-HMAC operations
for ipsec(4) and crypto(4).
The Hifn 7951, 7811, 7955, and 7956 will also supply data to the kernel random(4) subsystem.
HARDWARE
The hifn driver supports various cards containing the Hifn 7751, 7951, 7811, 7955, and 7956 chipsets, such as:
Invertex AEON No longer being made. Came as 128KB SRAM model, or 2MB DRAM model.
Hifn 7751 Reference board with 512KB SRAM.
PowerCrypt Comes with 512KB SRAM.
XL-Crypt Only board based on 7811 (which is faster than 7751 and has a random number generator).
NetSec 7751 Supports the most IPsec sessions, with 1MB SRAM.
Soekris Engineering vpn1201 and vpn1211
See http://www.soekris.com/. Contains a 7951 and supports symmetric and random number operations.
Soekris Engineering vpn1401 and vpn1411
See http://www.soekris.com/. Contains a 7955 and supports symmetric and random number operations.
SEE ALSO crypt(3), crypto(4), intro(4), ipsec(4), random(4), crypto(9)CAVEATS
The Hifn 9751 shares the same PCI ID. This chip is basically a 7751, but with the cryptographic functions missing. Instead, the 9751 is
only capable of doing compression. Since we do not currently attempt to use any of these chips to do compression, the 9751-based cards are
not useful.
Support for the 7955 and 7956 is incomplete; the asymmetric crypto facilities are to be added and the performance is suboptimal.
HISTORY
The hifn device driver appeared in OpenBSD 2.7. The hifn device driver was imported to FreeBSD 5.0.
BUGS
The 7751 chip starts out at initialization by only supporting compression. A proprietary algorithm, which has been reverse engineered, is
required to unlock the cryptographic functionality of the chip. It is possible for vendors to make boards which have a lock ID not known to
the driver, but all vendors currently just use the obvious ID which is 13 bytes of 0.
BSD October 19, 2009 BSD