NVD(4) BSD Kernel Interfaces Manual NVD(4)NAME
nvd -- NVM Express disk driver
To compile this driver into your kernel, place the following lines in your kernel configuration file:
Or, to load the driver as a module at boot, place the following lines in loader.conf(5):
The nvd driver exposes NVM Express (NVMe) namespaces as disks to the kernel disk storage API. It depends on the nvme(4) driver for notifica-
tion of existing NVMe namespaces and submission of NVM I/O commands.
Device nodes from the nvd driver will have the format /dev/nvdX and are GEOM(4) disks which can be partitioned by geom(8). Note that device
nodes from the nvme(4) driver are not GEOM(4) disks and cannot be partitioned.
SEE ALSO GEOM(4), nvme(4), geom(8), nvmecontrol(8), disk(9)HISTORY
The nvd driver first appeared in FreeBSD 9.2.
The nvd driver was developed by Intel and originally written by Jim Harris <jimharris@FreeBSD.org>, with contributions from Joe Golio at EMC.
This man page was written by Jim Harris <jimharris@FreeBSD.org>.
BSD March 18, 2014 BSD
Check Out this Related Man Page
GEOM_UZIP(4) BSD Kernel Interfaces Manual GEOM_UZIP(4)NAME
geom_uzip -- GEOM based compressed disk images
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The geom_uzip framework provides support for compressed read only disk images. This allows significant storage savings at the expense of a
little CPU time on each read. Data written in the GEOM label area allows geom_uzip to detect compressed images which have been created with
mkuzip(8) and presented to the kernel as a logical disk device via md(4). geom_uzip creates a unique md#.uzip device for each image.
The geom_uzip device is subsequently used by the FreeBSD kernel to access the disk images. The geom_uzip driver does not allow write opera-
tions to the underlying disk image. To check which md(4) devices match a given geom_uzip device:
# geom uzip list
Geom name: md1.uzip
1. Name: md1.uzip
Mediasize: 22003712 (21M)
1. Name: md1
Mediasize: 9563648 (9.1M)
SEE ALSO GEOM(4), md(4), geom(8), mkuzip(8)AUTHORS
The geom_uzip driver was written by Max Khon <fjoe@FreeBSD.org>. This manual page was written by Ceri Davies <ceri@FreeBSD.org>.
BSD October 9, 2006 BSD
We currently have a Solaris box connected to a Clariion storage system that is utilising DMP for path failover. I would prefer to use EMC's Powerpath and was wondering if the two can coexist?
Basically, I am struggling to find any documentation on the subject and was wonder if anyone can give me... (2 Replies)
First time writer....take it easy on me.
I had a situation where I lost all paths to EMC disk. There was a failure on the EMC frame. After that was repaired, my server had a difficult time reclaiming all disks and veritas had marked the disks as failed. Veritas was confused. What are some of... (3 Replies)
Could anybody help me how to configure a set of disk? From our existing EMC storage, we still have spaces for a new set of disk. I know how to replace a deffective disk but never had experience in setting/replacing a new pair of disk (M1 and M2). My objective here is to increase... (1 Reply)
This may sound like an absolute rookie question, and it is.
I have been working on Migrating our HP and Solaris servers to the new EMC SAN and know the routines backwards.
Now we've suddenly got a new IBM server and I don't even know how to check if it is connected to the switch.
Can someone... (1 Reply)
For HP-UX B.11.11-when new storage is allocated, i want to correlate the "ioscan -funC disk" o/p like,
disk 1110 0/0/8/0/0.97.49.19.0.9.4 sdisk CLAIMED DEVICE EMC SYMMETRIX
and so... (3 Replies)
Hello, we have a wierd and urgent problem, with a few of our p595 LPARs running AIX 5.3. The LPARs ran AIX 5.3 TL 7 and booted off EMC SAN disks, using EMC Powerpath. Every boot we run "pprootdev on" and "pprootdev fix". We can issue "bosboot -a" and we can reboot the machines.
Now, on two... (2 Replies)
I have a redhat 5.3 server which has 2 vg.. one is rootvg in local harddisk and another one is applicationvg in SAN.. When I reboot the server , EMC powerpath driver is not starting up automatically. Hence applicationvg is not mounting properly. Therefore I need to unmount it manually and... (4 Replies)
I hope I'm putting my first post at this site into the right forum. I need help finding the EMC disk driver for AIX version 5.3. I have some new EMC disk presented to a backup server of mine, and right now the EMC hdisks show up looking like this in an lsdev:
hdisk495 Available... (2 Replies)
I was trying to uninstall the native MPIO driver on the AIX 6.1 machine we have in our lab and ran into a whole bunch dependent filesets initially. I deleted the disks, fcsX, fscsiX, fcnetX and tried again, but ran into the same error.
Subsequently, I figured out that the OS disks in... (4 Replies)
On to a new implementation with AIX 7.1 san boot from EMC disks (Using NPIV). Anyone played with this recently?
Wondering if we need PowerPath on the AIX clients or has native MPIO matured to replace it. Thoughts?
Mr B (6 Replies)
I have few new EMC disks assigned from Stroage. I can pvcreate small disks (8.7GB), but bigger disks (71GB) are giving problem. -f also doesn't help.
root@tlcqr201:/> pvcreate /dev/emcpowerge
/dev/emcpowerge: read failed after 0 of 4096 at 0: Input/output error
/dev/emcpowerge: read failed... (2 Replies)
Some storage/disks have been added to an existing AIX 6.1 server. The admin sent me the list of hdisk#'s for the new disks, but I need the corresponding rhdisk# for the same hdisk. (I know from past experience that the rhdisk that maps to an hdisk is not always the same number. For instance,... (5 Replies)