Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

gpiobus(4) [freebsd man page]

GPIO(4) 						   BSD Kernel Interfaces Manual 						   GPIO(4)

NAME
gpiobus -- GPIO bus system SYNOPSIS
To compile these devices into your kernel and use the device hints, place the following lines in your kernel configuration file: device gpio device gpioc device gpioiic device gpioled Additional device entries for the ARM architecture include: device a10_gpio device bcm_gpio device imx51_gpio device lpcgpio device mv_gpio device ti_gpio device gpio_avila device gpio_cambria device zy7_gpio device pxagpio Additional device entries for the MIPS architecture include: device ar71xxx_gpio device octeon_gpio device rt305_gpio Additional device entries for the POWERPC architecture include: device wiigpio device macgpio DESCRIPTION
The gpiobus system provides a simple interface to the GPIO pins that are usually available on embedded architectures and can provide bit banging style devices to the system. The acronym GPIO means ``General-Purpose Input/Output.'' The BUS physically consists of multiple pins that can be configured for input/output, IRQ delivery, SDA/SCL iicbus use, etc. On some embedded architectures (like MIPS), discovery of the bus and configuration of the pins is done via device.hints(5) in the platform's kernel config(5) file. On some others (like ARM), where FDT(4) is used to describe the device tree, the bus discovery is done via the DTS passed to the kernel, being either statically compiled in, or by a variety of ways where the boot loader (or Open Firmware enabled system) passes the DTS blob to the kernel at boot. The following device.hints(5) are only provided by the ar71xx_gpio driver: hint.gpio.%d.pinmask This is a bitmask of pins on the GPIO board that we would like to expose for use to the host operating system. To expose pin 0, 4 and 7, use the bitmask of 10010001 converted to the hexadecimal value 0x0091. hint.gpio.%d.pinon This is a bitmask of pins on the GPIO board that will be set to ON at host start. To set pin 2, 5 and 13 to be set ON at boot, use the bitmask of 10000000010010 converted to the hexadecimal value 0x2012. hint.gpio.function_set hint.gpio.function_clear These are bitmasks of pins that will remap a pin to handle a specific function (USB, UART TX/RX, etc) in the Atheros function registers. This is mainly used to set/clear functions that we need when they are set up or not set up by uBoot. Simply put, each pin of the GPIO interface is connected to an input/output of some device in a system. SEE ALSO
gpioiic(4), gpioled(4), iicbus(4), gpioctl(8) HISTORY
The gpiobus manual page first appeared in FreeBSD 10.0. AUTHORS
This manual page was written by Sean Bruno <sbruno@FreeBSD.org>. BSD
November 5, 2013 BSD

Check Out this Related Man Page

SND_MAESTRO3(4) 					   BSD Kernel Interfaces Manual 					   SND_MAESTRO3(4)

NAME
snd_maestro3 -- ESS Maestro3/Allegro-1 bridge device driver SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file: device sound device snd_maestro3 Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): snd_maestro3_load="YES" DESCRIPTION
The snd_maestro3 driver provides support for the ESS Maestro3 and Allegro-1 sound chips under the PCM framework. These chips are mostly found in laptop computers and feature an AC97 mixer, a multi-channel sample rate converter that can mix up to four digital audio streams in hardware, recording support, and external volume control buttons. The firmware for the sound processor is licensed under the GNU Public License, and thus this driver is not included in the default GENERIC kernel. HARDWARE
The snd_maestro3 driver supports the following audio devices: o ESS Technology Allegro-1 o ESS Technology Maestro3 DIAGNOSTICS
The hardware volume control buttons can be connected to two different pin sets (GPIO or GD) on the chip, depending on the manufacturer. The driver has no way of determining this configuration, so a hint may be used to override the default guess. The default setting for hardware volume control assumes that GD pins are wired to control the hardware volume. For systems that have the GPIO pins wired to the hardware vol- ume control buttons, add the line ``hint.pcm.0.hwvol_config="0"'' to the file /boot/device.hints to override the default setting. SEE ALSO
sound(4), loader.conf(5) HISTORY
The snd_maestro3 driver first appeared in FreeBSD 4.3. AUTHORS
Scott Long <scottl@FreeBSD.org> Darrel Anderson <anderson@cs.duke.edu> BSD
December 15, 2005 BSD
Man Page

Featured Tech Videos