EHCI(4) BSD Kernel Interfaces Manual EHCI(4)NAME
ehci -- USB Enhanced Host Controller driver
SYNOPSIS
device ehci
DESCRIPTION
The ehci driver provides support for the USB Enhanced Host Controller Interface, which is used by USB 2.0 controllers.
EHCI controllers are peculiar in that they can only handle the USB 2.0 protocol. This means that they normally have one or more companion
controllers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Consequently each USB connector is electrically connected to two USB con-
trollers. The handling of this is totally automatic, but can be noticed since USB 1.x and USB 2.0 devices plugged in to the same connector
appear to connect to different USB busses.
SEE ALSO ohci(4), uhci(4), usb(4), xhci(4)HISTORY
The ehci device driver first appeared in FreeBSD 5.1.
LOADER TUNABLES
When the kernel has been compiled with options USB_DEBUG, some tunables become available that affect the behavior of ehci. These tunables
can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5).
hw.usb.ehci.lostintrbug
This tunable enables the lost interrupt quirk. The default value is 0 (off).
hw.usb.ehci.iaadbug
This tunable enables the EHCI doorbell quirk. The default value is 0 (off).
hw.usb.ehci.no_hs
This tunable disables USB devices to attach like HIGH-speed ones and will force all attached devices to attach to the FULL- or LOW-
speed companion controller. The default value is 0 (off).
BSD March 4, 2012 BSD
Check Out this Related Man Page
ehci(7D) Devices ehci(7D)NAME
ehci - Enhanced host controller driver
SYNOPSIS
usb@unit-address
DESCRIPTION
The ehci driver is a USBA (Solaris USB Architecture) compliant nexus driver that supports the Enhanced Host Controller Interface Specifica-
tion 2.0, an industry standard developed by Intel.
A USB 2.0 host controller includes one high-speed host controller and zero or more USB 1.1 host controllers. The high-speed host controller
implements an EHCI (Enhanced Host Controller Interface) that is used for all high-speed communications to high-speed-mode devices.
All USB 2.0 devices connected to the root ports of the USB 2.0 host controller and all devices connected to a high- speed-mode hub should
be routed to the EHCI host controller.
All full- and low-speed devices connected to the root ports of the USB 2.0 host controller should be routed to the companion USB 1.1 host
controllers. (OHCI or UHCI host controller).
The ehci supports bulk, interrupt, control and iso chronous transfers (on USB1.x devices behind a USB2.0 hub).
FILES
/kernel/drv/ehci 32-bit ELF 86 kernel module
/kernel/drv/sparcv9/ehci 64-bit SPARC ELF kernel module
/kernel/drv/amd64/ehci 64-bit x86 ELF kernel module
/kernel/drv/ehci.conf Driver configuration file
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
+-----------------------------+------------------------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+-----------------------------+------------------------------+
|Architecture |SPARC, x86, PCI-based systems |
+-----------------------------+------------------------------+
|Availability |SUNWusb |
+-----------------------------+------------------------------+
SEE ALSO add_drv(1M), prtconf(1M), rem_drv(1M), update_drv(1M), attributes(5), hubd(7D), uhci(7D), ohci(7D), usba(7D)
Writing Device Drivers
Universal Serial Bus Specification 2.0
Enhanced Host Controller Interface Specification 1.0
System Administration Guide: Basic Administration
http://www.usb.org
http://www.sun.com/io
http://www.sun.com/bigadmin/hcl
http://www.intel.com/technology/usb/ehcispec.htm
DIAGNOSTICS
In addition to being logged, the following messages may appear on the system console. All messages are formatted in the following manner:
WARNING: <device path> (ehci<instance number>): Message...
Unrecoverable USB hardware error.
There was an unrecoverable USB hardware error reported by the ehci controller. Reboot the system. If this problem persists, contact
your system vendor.
No SOF interrupts.
No SOF interrupts have been received. This USB EHCI controller is unusable.
Error recovery failure: Please hotplug the 2.0 hub at <device path>.
The driver failed to clear 2.0 hub's TT buffer. Remove and reinsert the external USB2.0 hub.
Revision<xx> is not supported.
High speed USB devices prior to revision 0.95 are not supported.
The following messages may be entered into the system log. They are formatted in the following manner:
<device path> (ehci<instance number>): Message...
Unable to take control from BIOS. Failure is ignored.
The driver was unable to take control of the EHCI hardware from the system's BIOS. This failure is ignored. To abort the attach on this
take-over failure, comment out a property in ehci.conf. (x86 only).
Unable to take control from BIOS.
The driver is unable to take control of the EHCI hardware from the system's BIOS and aborts the attach. High speed (USB 2.0)
support is disabled. In this case, all USB devices run at full/low speed. Contact your system vendor or your system administror for
possible changes in BIOS settings. You can disable a property in ehci.conf to ignore this failure. (x86 only.)
Low speed device is not supported.
Full speed device is not supported.
The driver detected a low or full speed device on its root hub port. Per USB 2.0 specification, the device should be routed to a com-
panion host controller (OHCI or UHCI). However, no attached companion host controller appears to be available. Therefore, low and full
speed devices are not supported.
Low speed endpoint's poll interval of <n> ms is below threshold. Rounding up to 8 ms.
Low speed endpoints are limited to polling intervals between 8 ms and 255 ms. If a device reports a polling interval that is less than
8 ms, the driver uses 8 ms instead.
Low speed endpoint's poll interval is greater than 255 ms.
The low speed device's polling interval is out of range. The host controller does not allocate bandwidth for this device. This device
is not usable.
Full speed endpoint's poll interval must be between 1 and 255 ms.
The full speed device's polling interval is out of range. The host controller does not allocate bandwidth for this device. This device
is not usable.
High speed endpoint's poll interval must be between 1 and 16 units.
The high speed device's polling interval is out of range. The host controller will not allocate bandwidth for this device. This device
will not be usable. Refer to the USB specification, revision 2.0 for the unit definition.
ehci_modify_qh_status_bit: Failed to halt qh=<address>.
Error recovery failed. Please disconnect and reinsert all devices or reboot.
Note -
Due to recently discovered incompatibilities with this USB controller, USB2.x transfer support has been disabled. However, this device
continues to function as a USB1.x controller. Information on enabling USB2.x support is provided in this man page. Please refer to
www.sun.com/io for Solaris Ready products and to www.sun.com/bigadmin/hcl for additional compatible USB products.
VIA chips may not be compatible with this driver. To bind ehci specifically to the chip and eliminate the warnings, and to enable USB2.x
suppport, a new, more specific driver alias (refer to add_drv(1M) and update_drv(1M)) must be specified for ehci. By default, the ehci
alias is 'pciclass,0c0320.' The compatible names in the prtconf(1M) output provides additional aliases. For example:
# prtconf -vp | grep pciclass,0c0320
compatible: 'pci1106,3104.1106.3104.2063' +
'pci1106,3104.1106.3104' + 'pci1106,3104' +
pci1106,3104.2063' + 'pci1106,3104' + 'pciclass,0c0320' +
'pciclass,0c03'
....
A more specific alias is 'pci1106,3104.' Perform the follow-
ing step to add this alias, then reboot the system:
# update_drv -a -i '"pci1106,3104"' ehci
# reboot
After you apply the above workaround, the following message is displayed in your system log:
Applying VIA workarounds.
SunOS 5.11 13 April 2006 ehci(7D)