BKTR(4) BSD Kernel Interfaces Manual BKTR(4)
bktr -- Brooktree Bt848/849/878/879 and Pinnacle PCTV video capture driver
The bktr driver provides support for PCI video capture and VBI capture on low cost, high performance boards. The driver is based on the
Matrox Meteor driver and uses the same API. The bktr driver should support most video cards based on the Brooktree Bt848/849/878/879 Video
Capture Chip. Also supported are most Pinnacle PCTV video cards. Furthermore, the driver supports FM Radio if the tuner supports it.
The driver currently supports the following features:
PCI to PCI dma transfer
On the supported cards, tuners and other components are interconnected with an I2C bus. The Brooktree848 chips act as a master device on the
bus to control them. Therefore, iicbus(4), iicbb(4) and smbus(4) controller declarations are mandatory to activate bktr support.
The following kernel parameters may be used to further configure the driver:
options BROOKTREE_ALLOC_PAGES=xxx specifies the number of contiguous pages to allocate when successfully probed. The default number of pages
allocated by the kernel is 216. This means that there are (216*4096) bytes available for use.
One of these options can be used to set the default video format for the driver. This fixed random hangs and lockups with the VideoLogic
Captivator PCI card.
The following sysctls may be used to further configure the driver:
sysctl hw.bt848.card=nnnn This can be used to override the card make which was detected at boot time. 'nnnn' is set to an integer from 1 to
23 taken from the following table:
sysctl hw.bt848.tuner=nnnn This can be used to override the tuner make which was detected at boot time. 'nnnn' is set to an integer from 0
to 16 taken from the following table:
PHILIPS_FR1236_NTSC 9 /* These have FM Radio support */
PHILIPS_FR1216_PAL 10 /* These have FM Radio support */
PHILIPS_FR1236_SECAM 11 /* These have FM Radio support */
The bktr driver supports video capture cards based on the Brooktree Bt848/849/878/879 chips, as well as Pinnacle PCTV cards, including:
o AOpen VA1000
o AVerMedia AVerTV Studio
o AVerMedia TF/FM-98
o ATI TV Wonder VE
o Hauppauge WinCast/TV
o Hauppauge WinTV-Go-FM
o Hauppauge WinTV-pci
o Hauppauge WinTV-radio
o Intel Smart Video Recorder III
o KWORLD PCI TV Tuner
o Miro PC TV
o Pinnacle PCTV Pro
o Pinnacle PCTV Rave
o PixelView PlayTV PAK
o PixelView PlayTV Pro (rev 4C, 9D)
o SIGMA TV II
o STB TV PCI Television Tuner
o Super TV Tuner
o TerraTec TValue
o V-Stream XPERT TV-PVR 878
o Video Highway XTreme
o VideoLogic Captivator PCI
/usr/share/examples/meteor Examples of what you can do with the (similarly designed) Meteor driver.
/usr/ports/multimedia/fxtv A TV and Camera display program utilizing the bktr driver - requires that The X Window System and The Ports
Collection also be installed.
/usr/ports/misc/alevt A program to capture and display Teletext (VideoText) pages - requires that The X Window System and The Ports
Collection also be installed.
/usr/ports/audio/xmradio An FM Radio Tuner for cards which have an FM Radio tuner fitted - requires that The X Window System and The Ports
Collection also be installed. It also requires Motif or the lesstif port.
The bktr driver first appeared in FreeBSD 2.2.
This driver is based on the work of Jim Lowe <email@example.com>, Mark Tinguely <firstname.lastname@example.org>, Amancio Hasty
<email@example.com>, Roger Hardiman <roger@FreeBSD.org> and a bunch of other people. Support for Pinnacle PCTV Rave cards was added by
Branko Lankester <firstname.lastname@example.org>.
January 18, 2006 BSD