Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

glxqueryextension(3g) [centos man page]

GLXQUERYEXTENSION(3G)						   OpenGL Manual					     GLXQUERYEXTENSION(3G)

NAME
glXQueryExtension - indicate whether the GLX extension is supported C SPECIFICATION
Bool glXQueryExtension(Display * dpy, int * errorBase, int * eventBase); PARAMETERS
dpy Specifies the connection to the X server. errorBase Returns the base error code of the GLX server extension. eventBase Returns the base event code of the GLX server extension. DESCRIPTION
glXQueryExtension returns True if the X server of connection dpy supports the GLX extension, False otherwise. If True is returned, then errorBase and eventBase return the error base and event base of the GLX extension. These values should be added to the constant error and event values to determine the actual event or error values. Otherwise, errorBase and eventBase are unchanged. errorBase and eventBase do not return values if they are specified as NULL. SEE ALSO
glXQueryVersion() COPYRIGHT
Copyright (C) 1991-2006 Silicon Graphics, Inc. This document is licensed under the SGI Free Software B License. For details, see http://oss.sgi.com/projects/FreeB/. AUTHORS
opengl.org opengl.org 06/10/2014 GLXQUERYEXTENSION(3G)

Check Out this Related Man Page

GLXGETSELECTEDEVENT(3G) 					   OpenGL Manual					   GLXGETSELECTEDEVENT(3G)

NAME
glXGetSelectedEvent - returns GLX events that are selected for a window or a GLX pixel buffer C SPECIFICATION
void glXGetSelectedEvent(Display * dpy, GLXDrawable draw, unsigned long * event_mask); PARAMETERS
dpy Specifies the connection to the X server. draw Specifies a GLX drawable. Must be a GLX pixel buffer or a window. event_mask Returns the events that are selected for draw. DESCRIPTION
glXGetSelectedEvent returns in event_mask the events selected for draw. NOTES
glXGetSelectedEvent is available only if the GLX version is 1.3 or greater. If the GLX version is 1.1 or 1.0, the GL version must be 1.0. If the GLX version is 1.2, then the GL version must be 1.1. If the GLX version is 1.3, then the GL version must be 1.2. ERRORS
GLXBadDrawable is generated if draw is not a valid window or a valid GLX pixel buffer. SEE ALSO
glXSelectEvent(), glXCreatePbuffer() COPYRIGHT
Copyright (C) 1991-2006 Silicon Graphics, Inc. This document is licensed under the SGI Free Software B License. For details, see http://oss.sgi.com/projects/FreeB/. AUTHORS
opengl.org opengl.org 06/10/2014 GLXGETSELECTEDEVENT(3G)
Man Page

Featured Tech Videos