Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

scsi_destroy_pkt(9f) [bsd man page]

scsi_destroy_pkt(9F)					   Kernel Functions for Drivers 				      scsi_destroy_pkt(9F)

NAME
scsi_destroy_pkt - free an allocated SCSI packet and its DMA resource SYNOPSIS
#include <sys/scsi/scsi.h> void scsi_destroy_pkt(struct scsi_pkt *pktp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
pktp Pointer to a scsi_pkt(9S) structure. DESCRIPTION
scsi_destroy_pkt() releases all necessary resources, typically at the end of an I/O transfer. The data is synchronized to memory, then the DMA resources are deallocated and pktp is freed. CONTEXT
scsi_destroy_pkt() may be called from user or interrupt context. EXAMPLES
Example 1: Releasing resources. scsi_destroy_pkt(un->un_rqs); SEE ALSO
tran_destroy_pkt(9E), scsi_init_pkt(9F), scsi_pkt(9S) Writing Device Drivers SunOS 5.10 30 Aug 1995 scsi_destroy_pkt(9F)

Check Out this Related Man Page

scsi_sync_pkt(9F)					   Kernel Functions for Drivers 					 scsi_sync_pkt(9F)

NAME
scsi_sync_pkt - synchronize CPU and I/O views of memory SYNOPSIS
#include <sys/scsi/scsi.h> void scsi_sync_pkt(struct scsi_pkt *pktp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
pktp Pointer to a scsi_pkt(9S) structure. DESCRIPTION
scsi_sync_pkt() is used to selectively synchronize a CPU's or device's view of the data associated with the SCSI packet that has been mapped for I/O. This may involve operations such as flushes of CPU or I/O caches, as well as other more complex operations such as stalling until hardware write buffers have drained. This function need only be called under certain circumstances. When a SCSI packet is mapped for I/O using scsi_init_pkt(9F) and destroyed using scsi_destroy_pkt(9F), then an implicit scsi_sync_pkt() will be performed. However, if the memory object has been modified by either the device or a CPU after the mapping by scsi_init_pkt(9F), then a call to scsi_sync_pkt() is required. If the same scsi_pkt is reused for a data transfer from memory to a device, then scsi_sync_pkt() must be called before calling scsi_trans- port(9F). If the same packet is reused for a data transfer from a device to memory scsi_sync_pkt() must be called after the completion of the packet but before accessing the data in memory. CONTEXT
scsi_sync_pkt() may be called from user or interrupt context. SEE ALSO
tran_sync_pkt(9E), ddi_dma_sync(9F), scsi_destroy_pkt(9F), scsi_init_pkt(9F), scsi_transport(9F), scsi_pkt(9S) Writing Device Drivers SunOS 5.10 25 Feb 1994 scsi_sync_pkt(9F)
Man Page

10 More Discussions You Might Find Interesting

1. OS X (Apple)

Mac OS X: Based on UNIX - Solid As a Rock

See this threads: Page Not Found - Apple Open Source - Apple (0 Replies)
Discussion started by: Neo
0 Replies

2. UNIX for Beginners Questions & Answers

Simple rules of the UNIX.COM forums:

RULES OF THE UNIX AND LINUX FORUMS For the latest version of the community rules (the official community rules page), please visit here. No flames, shouting (all caps), sarcasm, bullying, profanity or arrogant posts. No negative comments about others or impolite remarks. Be patient. No... (1 Reply)
Discussion started by: Neo
1 Replies

3. Shell Programming and Scripting

Scripts without shebang

I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning . Does this mean that it will run on any shell ? Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Discussion started by: kraljic
16 Replies

4. Fedora

Is UNIX an open source OS ?

Hi everyone, I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX. Ok onto business, my questions are-: Was/Is UNIX ever an open source operating system ? If UNIX was... (21 Replies)
Discussion started by: sreyan32
21 Replies

5. UNIX for Beginners Questions & Answers

Memory leak with awk on MacOs

Dear all, I use awk quite a bit for data wrangling ... today I find weird behavior that I cannot wrap my head around. if I execute the following command (simplified to illustrate the behavior ... nothing to do with the real command) bash-3.2$ awk... (3 Replies)
Discussion started by: comm|getline
3 Replies

6. Shell Programming and Scripting

Mail/mailx ignores newline formatting Problem.

I have a file hello.txt which i wish to send as a email body (not attachment). cat -ev hello.txt 1$ 2$ 3$ I use the following command to send the hello.txt as the email body. mailx -s "Alert" myteam@mycomp.com<hello.txt However, the email received has this in the email body 123... (2 Replies)
Discussion started by: mohtashims
2 Replies

7. Linux

LM 19.1 from pendrive

I've "installed" LM 19.1 to a PNY 16Gb(2.0) pendrive. I have a few issues that I'd like to resolve. First and foremost, the O.S. experiences "lagging" issues and to a lesser degree, freezing. Example: Complete "boot-up" (from start to complete "home" page) can take upwards of 7 mins. Then when... (10 Replies)
Discussion started by: 69Rixter
10 Replies

8. UNIX for Beginners Questions & Answers

UNIX Environment Setup - (Just starting!)

Morning All So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question: Currently I use Oracle VirtualBox, can... (8 Replies)
Discussion started by: GophusMeau
8 Replies

9. Solaris

Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?

I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager. FreeBSD slices are as follows; / on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f. I hesitate to install Solaris 10... (2 Replies)
Discussion started by: vectrum
2 Replies

10. UNIX for Advanced & Expert Users

[Tip] How to display the number of logged-in users

In a professional environment with traditional application you often want (or are asked) to report the users. Traditionally there is the who command who | awk '{print $1}'telnetd or sshd register the users in the utmp file, to be shown with who, w, users, finger, pinky, ... In addition they... (1 Reply)
Discussion started by: MadeInGermany
1 Replies