freerbuf(9F) Kernel Functions for Drivers freerbuf(9F)NAME
freerbuf - free a raw buffer header
SYNOPSIS
#include <sys/buf.h>
#include <sys/ddi.h>
void freerbuf(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to a previously allocated buffer header structure.
DESCRIPTION
freerbuf() frees a raw buffer header previously allocated by getrbuf(9F). This function does not sleep and so may be called from an inter-
rupt routine.
CONTEXT
freerbuf() can be called from user or interrupt context.
SEE ALSO getrbuf(9F), kmem_alloc(9F), kmem_free(9F), kmem_zalloc(9F)SunOS 5.10 11 Apr 1991 freerbuf(9F)
Check Out this Related Man Page
bioreset(9F) Kernel Functions for Drivers bioreset(9F)NAME
bioreset - reuse a private buffer header after I/O is complete
SYNOPSIS
#include <sys/buf.h>
#include <sys/ddi.h>
void bioreset(struct buf *bp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
bp Pointer to the buf(9S) structure.
DESCRIPTION
bioreset() is used by drivers that allocate private buffers with getrbuf(9F) or kmem_alloc(9F) and want to reuse them in multiple transfers
before freeing them with freerbuf(9F) or kmem_free(9F). bioreset() resets the buffer header to the state it had when initially allocated by
getrbuf() or initialized by bioinit(9F).
CONTEXT
bioreset() can be called from any context.
SEE ALSO strategy(9E), bioinit(9F), biofini(9F), freerbuf(9F), getrbuf(9F), kmem_alloc(9F), kmem_free(9F), buf(9S)NOTES
bp must not describe a transfer in progress.
SunOS 5.10 15 Nov 1996 bioreset(9F)
RULES OF THE UNIX AND LINUX FORUMS
For the latest version of the community rules (the official community rules page), please visit here.
No flames, shouting (all caps), sarcasm, bullying, profanity or arrogant posts.
No negative comments about others or impolite remarks. Be patient. No... (1 Reply)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
Dear all,
I use awk quite a bit for data wrangling ... today I find weird behavior that I cannot wrap my head around.
if I execute the following command (simplified to illustrate the behavior ... nothing to do with the real command)
bash-3.2$ awk... (3 Replies)
I have a file hello.txt which i wish to send as a email body (not attachment).
cat -ev hello.txt
1$
2$
3$
I use the following command to send the hello.txt as the email body.
mailx -s "Alert" myteam@mycomp.com<hello.txt
However, the email received has this in the email body
123... (2 Replies)
I've "installed" LM 19.1 to a PNY 16Gb(2.0) pendrive. I have a few issues that I'd like to resolve. First and foremost, the O.S. experiences "lagging" issues and to a lesser degree, freezing. Example: Complete "boot-up" (from start to complete "home" page) can take upwards of 7 mins. Then when... (10 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
In a professional environment with traditional application you often want (or are asked) to report the users.
Traditionally there is the who command
who | awk '{print $1}'telnetd or sshd register the users in the utmp file, to be shown with who, w, users, finger, pinky, ...
In addition they... (1 Reply)