biofini(9F) Kernel Functions for Drivers biofini(9F)NAME
biofini - uninitialize a buffer structure
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
voidbiofini(struct buf *bp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
bp Pointer to the buffer header structure.
DESCRIPTION
The biofini() function uninitializes a buf(9S) structure. If a buffer structure has been allocated and initialized using kmem_alloc(9F) and
bioinit(9F) it needs to be uninitialized using biofini() before calling kmem_free(9F). It is not necessary to call biofini() before freeing
a buffer structure using freerbuf(9F) because freerbuf() will call biofini() directly.
CONTEXT
The biofini() function can be called from any context.
EXAMPLES
Example 1: Using biofini()
struct buf *bp = kmem_alloc(biosize(), KM_SLEEP);
bioinit(bp);
/* use buffer */
biofini(bp);
kmem_free(bp, biosize());
SEE ALSO bioinit(9F), bioreset(9F), biosize(9F), freerbuf(9F), kmem_alloc(9F), kmem_free(9F), buf(9S)
Writing Device Drivers
SunOS 5.10 20 Nov 1996 biofini(9F)
Check Out this Related Man Page
biofini(9F) Kernel Functions for Drivers biofini(9F)NAME
biofini - uninitialize a buffer structure
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
voidbiofini(struct buf *bp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
bp Pointer to the buffer header structure.
DESCRIPTION
The biofini() function uninitializes a buf(9S) structure. If a buffer structure has been allocated and initialized using kmem_alloc(9F) and
bioinit(9F) it needs to be uninitialized using biofini() before calling kmem_free(9F). It is not necessary to call biofini() before freeing
a buffer structure using freerbuf(9F) because freerbuf() will call biofini() directly.
CONTEXT
The biofini() function can be called from any context.
EXAMPLES
Example 1: Using biofini()
struct buf *bp = kmem_alloc(biosize(), KM_SLEEP);
bioinit(bp);
/* use buffer */
biofini(bp);
kmem_free(bp, biosize());
SEE ALSO bioinit(9F), bioreset(9F), biosize(9F), freerbuf(9F), kmem_alloc(9F), kmem_free(9F), buf(9S)
Writing Device Drivers
SunOS 5.10 20 Nov 1996 biofini(9F)
RULES OF THE UNIX AND LINUX FORUMS
For the latest version of the community rules (the official community rules page), please visit here.
No flames, shouting (all caps), sarcasm, bullying, profanity or arrogant posts.
No negative comments about others or impolite remarks. Be patient. No... (1 Reply)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
Dear all,
I use awk quite a bit for data wrangling ... today I find weird behavior that I cannot wrap my head around.
if I execute the following command (simplified to illustrate the behavior ... nothing to do with the real command)
bash-3.2$ awk... (3 Replies)
I have a file hello.txt which i wish to send as a email body (not attachment).
cat -ev hello.txt
1$
2$
3$
I use the following command to send the hello.txt as the email body.
mailx -s "Alert" myteam@mycomp.com<hello.txt
However, the email received has this in the email body
123... (2 Replies)
I've "installed" LM 19.1 to a PNY 16Gb(2.0) pendrive. I have a few issues that I'd like to resolve. First and foremost, the O.S. experiences "lagging" issues and to a lesser degree, freezing. Example: Complete "boot-up" (from start to complete "home" page) can take upwards of 7 mins. Then when... (10 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
In a professional environment with traditional application you often want (or are asked) to report the users.
Traditionally there is the who command
who | awk '{print $1}'telnetd or sshd register the users in the utmp file, to be shown with who, w, users, finger, pinky, ...
In addition they... (1 Reply)