Query: store
OS: opendarwin
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
STORE(9) BSD Kernel Developer's Manual STORE(9)NAMEstore, subyte, susword, suswintr, suword -- store data to user-spaceSYNOPSIS#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> #include <sys/resourcevar.h> int subyte(void *base, int byte); int susword(void *base, int word); int suswintr(void *base, int word); int suword(void *base, long word);DESCRIPTIONThe store functions are designed to copy small amounts of data to user-space. The store routines provide the following functionality: subyte() Stores a byte of data to the user-space address base. susword() Stores a short word of data to the user-space address base. suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context. suword() Stores a word of data to the user-space address base.RETURN VALUESThe store functions return 0 on success or -1 on failure.SEE ALSOcopy(9), fetch(9)BSDJanuary 7, 1996 BSD
Related Man Pages |
---|
subyte(9) - debian |
store(9) - debian |
suword(9) - debian |
suword64(9) - debian |
suword32(9) - freebsd |
Similar Topics in the Unix Linux Community |
---|
At the Apple Store in McLean... |
Run stored procedure from shell script |
How to read values and store in array? |
Ufsrestore |
Restore .dmg containing multiple partitions to bootable USB flash drive |