bsd man page for devclass_get_devices

Query: devclass_get_devices

OS: bsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVCLASS_GET_DEVICES(9) 				   BSD Kernel Developer's Manual				   DEVCLASS_GET_DEVICES(9)

NAME
devclass_get_devices -- get a list of devices in a devclass
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int devclass_get_devices(devclass_t dc, device_t **devlistp, int *devcountp);
DESCRIPTION
Retrieve a list of all device instances currently in the devclass and return the list in *devlistp and the count in *devcountp. The memory allocated for the list should be freed using free(*devlistp, M_TEMP), even if *devcountp is 0.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
devclass(9), device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
May 19, 2005 BSD
Related Man Pages
devclass(9) - debian
device(9) - debian
driver(9) - debian
device(9) - freebsd
devclass(9) - linux
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Scripts without shebang
Is UNIX an open source OS ?
[Tip] How to display the number of logged-in users
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?