MKNOD(8) System Manager's Manual MKNOD(8)NAME
mknod - build special file
/sbin/mknod name [ c ] [ b ] major minor
Mknod makes a special file. The first argument is the name of the entry. The second is b if the special file is block-type (disks, tape)
or c if it is character-type (other devices). The last two arguments are numbers specifying the major device type and the minor device
(e.g. unit, drive, or line number).
The assignment of major device numbers is specific to each system. They have to be dug out of the system source file conf.c.
SEE ALSO mknod(2), makedev(8)4th Berkeley Distribution November 16, 1996 MKNOD(8)
Check Out this Related Man Page
MKNOD(8) BSD System Manager's Manual MKNOD(8)NAME
mknod -- make device special file
mknod [-F format] name [c | b] major minor
mknod [-F format] name [c | b] major unit subunit
mknod name [c | b] number
mknod name w
The mknod command creates device special files.
To make nodes manually, the required arguments are:
name Device name, for example ``sd'' for a SCSI disk on an HP300 or a ``pty'' for pseudo-devices.
b | c | w
Type of device. If the device is a block type device such as a tape or disk drive which needs both cooked and raw special files, the
type is b. Whiteout nodes are type w. All other devices are character type devices, such as terminal and pseudo devices, and are
major The major device number is an integer number which tells the kernel which device driver entry point to use.
minor The minor device number tells the kernel which one of several similar devices the node corresponds to; for example, it may be a spe-
cific serial port or pty.
unit and subunit
The unit and subunit numbers select a subset of a device; for example, the unit may specify a particular SCSI disk, and the subunit a
partition on that disk. (Currently this form of specification is only supported by the bsdos format, for compatibility with the
Device numbers for different operating systems may be packed in a different format. To create device nodes that may be used by such an oper-
ating system (e.g. in an exported file system used for netbooting), the -F option is used. The following formats are recognized: native,
386bsd, 4bsd, bsdos, freebsd, hpux, isc, linux, netbsd, osf1, sco, solaris, sunos, svr3, svr4 and ultrix.
Alternatively, a single opaque device number may be specified.
SEE ALSO mkfifo(1), mkfifo(2), mknod(2)HISTORY
A mknod command appeared in Version 6 AT&T UNIX. The -F option appeared in NetBSD 1.4.
NetBSD 1.4 September 11, 1998 NetBSD 1.4
Can someone please tell me what the command mknod does and what it's syntax is? I can't find it in my "Unix for dummies" book or "Unix in s nutshell". I found it in an existing script that I want to copy, but I want to understand what I am doing. The script is going to do a full export of an... (3 Replies)
I'm trying to use the "mknod" call in C to create a clone of /dev/null. I am stumped as to the final parameter I should provide to "mknod()". I am supposed to give it a type dev_t, which specifies a major & minor number. I want to specify major 3, minor 1, but how can I do this?
dev_t seems to... (2 Replies)
this is existing issue for this nfs client, which mounts windows exported
file system, and this is only one UNIX box has this problem, other boxes are
Here is from messages file.
Jan 24 03:11:10 venus nfs: NFS mknod failed for
server arc: error 2 (RPC: Can't decode result)
Jan... (0 Replies)
Friends i know mknod with -p option is used to create FIFO special file.:p
But i want to know some circumstance/scenario where these are used.:wall:
Actually i want to know where i can use it in real time.
Please advise.:) (3 Replies)
On my AIX server , I have this file "mknod" present in the /etc/ directory. When i try opening it , I dont find
any ascii characters. It shows some encryption/binary format which is not readable. Is it any executable ? what is the
purpose of having this file in etc folder? what if... (2 Replies)
I need to backup my database but the files are very large and the TAR command will not let me. I searched aids and found that I could do something with the mknod, COMPRESS and TAR command using them together. I appreciate your help. (10 Replies)