KGMON(8) System Manager's Manual KGMON(8)NAME
kgmon - generate a dump of the operating system's profile buffers
/usr/sbin/kgmon [ -b ] [ -h ] [ -r ] [ -p ] [ system ] [ memory ]
Kgmon is a tool used when profiling the operating system. When no arguments are supplied, kgmon indicates the state of operating system
profiling as running, off, or not configured. (see config(8)) If the -p flag is specified, kgmon extracts profile data from the operating
system and produces a gmon.out file suitable for later analysis by gprof(1).
The following options may be specified:
-b Resume the collection of profile data.
-h Stop the collection of profile data.
-p Dump the contents of the profile buffers into a gmon.out file.
-r Reset all the profile buffers. If the -p flag is also specified, the gmon.out file is generated before the buffers are reset.
If neither -b nor -h is specified, the state of profiling collection remains unchanged. For example, if the -p flag is specified and pro-
file data is being collected, profiling will be momentarily suspended, the operating system profile buffers will be dumped, and profiling
will be immediately resumed.
/vmunix - the default system
/dev/kmem - the default memory
SEE ALSO gprof(1), config(8)DIAGNOSTICS
Users with only read permission on /dev/kmem cannot change the state of profiling collection. They can get a gmon.out file with the warn-
ing that the data may be inconsistent if profiling is in progress.
4.2 Berkeley Distribution November 17, 1996 KGMON(8)
Check Out this Related Man Page
MONCONTROL(3) BSD Library Functions Manual MONCONTROL(3)NAME
moncontrol, monstartup -- control execution profile
monstartup(u_long *lowpc, u_long *highpc);
An executable program compiled using the -pg option to cc(1) automatically includes calls to collect statistics for the gprof(1) call-graph
execution profiler. In typical operation, profiling begins at program startup and ends when the program calls exit. When the program exits,
the profiling data are written to the file gmon.out, then gprof(1) can be used to examine the results.
moncontrol() selectively controls profiling within a program. When the program starts, profiling begins. To stop the collection of his-
togram ticks and call counts use moncontrol(0); to resume the collection of histogram ticks and call counts use moncontrol(1). This feature
allows the cost of particular operations to be measured. Note that an output file will be produced on program exit regardless of the state
Programs that are not loaded with -pg may selectively collect profiling statistics by calling monstartup() with the range of addresses to be
profiled. lowpc and highpc specify the address range that is to be sampled; the lowest address sampled is that of lowpc and the highest is
just below highpc. Only functions in that range that have been compiled with the -pg option to cc(1) will appear in the call graph part of
the output; however, all functions in that address range will have their execution time measured. Profiling begins on return from
gmon.out execution data file
SEE ALSO cc(1), gprof(1), profil(2)4th Berkeley Distribution June 4, 1993 4th Berkeley Distribution
I have a string like this.
$str="The astrocyte profile might contribute to the identification of possible therapies in profiles profiling and profiled als.";
Lets consider for example:
a)If user enters the term profile* it should highlight profile,profiles only.
b)If user enters the... (3 Replies)
Hey guys! this is my first post on this site. I was hoping you guys could help me out. I am going to be a senior this year and I want to build an operating system from scratch or at least do as much of as I can by myself. I want to build nothing big like ubuntu but something smaller looking that... (10 Replies)
Users connecting to AIX server face disconnection after a period of inactivity. I have tried checking the /etc/profile.The TMOUT value seems to be 0.However there is disconnection being faced. Can someone help me to identify other areas that I probably may be missing. (4 Replies)
So it goes like this...
I logged in to the HMC console , trying to change the memory of LPAR from 20 to 25 GB . It says that "your profile is configured to use maximum of only 20 GB" and not able to increase the memory.
I created a new profile and filled "maximum memory " field... (4 Replies)