SERVICES(5) File Formats Manual SERVICES(5)NAME
services - service name data base
The services file contains information regarding the known services available in the DARPA Internet. For each service a single line should
be present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The port number and protocol name are considered a single item; a ``/''
is used to separate the port and protocol (e.g. ``512/tcp''). A ``#'' indicates the beginning of a comment; characters up to the end of
the line are not interpreted by routines which search the file.
Service names may contain any printable character other than a field delimiter, newline, or comment character.
SEE ALSO getservent(3N)BUGS
A name server should be used instead of a static file.
4.2 Berkeley Distribution May 6, 1986 SERVICES(5)
Check Out this Related Man Page
services(4) File Formats services(4)NAME
services - Internet services and aliases
The services file is a local source of information regarding each service available through the Internet. The services file can be used in
conjunction with or instead of other services sources, including the NIS maps "services.byname" and the NIS+ table "services." Programs
use the getservbyname(3SOCKET) routines to access this information.
The services file contains an entry for each service. Each entry has the form:
service-name port/protocol aliases
service-name This is the official Internet service name.
port/protocol This field is composed of the port number and protocol through which the service is provided, for instance, 512/tcp.
aliases This is a list of alternate names by which the service might be requested.
Fields can be separated by any number of SPACE and/or TAB characters. A number sign (#) indicates the beginning of a comment; any charac-
ters that follow the comment character up to the end of the line are not interpreted by routines which search the file.
Service names may contain any printable character other than a field delimiter, a NEWLINE, or a comment character.
Any changes to a port assignment do not affect the actual port registration of the service.
/etc/nsswitch.conf configuration file for name-service switch
SEE ALSO getservbyname(3SOCKET), inetd.conf(4), nsswitch.conf(4)NOTES
/etc/inet/services is the official SVR4 name of the services file. The symbolic link /etc/services exists for BSD compatibility.
SunOS 5.11 12 Oct 2000 services(4)
Is there a method to transfer a file from UNIX (AIX) to an NT box
without the NT box having any special software running? I can ping the box via the network and I have a valid NT account to use.
Is FTP a viable solution ?
HELP! (10 Replies)
I need to use the RSH command to run a shell script on my Unix box from Win 2000. I'm using the etc/hosts.equiv file for configuring Unix. In it I have the hostname and username as required. As a test, I enter the following on the Win 2000 dos command: rsh servername -l username df -k.
The... (8 Replies)
I was just asked if I had any experience with MC ServiceGuard with HP-UX, when I used HP I didn't use it but I am curious about it and would like to see about learning it (it seems lots of HP jobs want experience with it.) Also is this a HP product or is it used on other types of *nix. Thanks for... (10 Replies)
I am a new comer in this forum.
When I try to send email in my Linux machine with command "mail" or "sendmail", I always find it include the IP address of my machine in the email header. Does anybody know how to eliminate this IP address or replace it with a fake one in the email... (20 Replies)
I want to add auto startup and shutdown script to Solaris 10's legacy services as they run in Solaris 9 or in Linux.
To make this work, I created the crontrol script in /etc/init.d and then link it to /etc/rc0.d and /etc/rc2.d directories. rc0.d is for shutdown and rc2.d is for srat. After I... (15 Replies)
OK I am a complete newbie to Unix. We have a Sunfire V890 running SUNOS Release 5.9. The Operating Environment is Solaris 9. I have been tasked with determining whether or not specific network and solaris services are enabled or disabled. If the services are enabled I need to disable them. I'm... (12 Replies)
I have 3 solaris servers. Two servers of differnet network and one gateway.
Server1 --> 192.168.0.1 --> Solaris 9
Server2 --> 10.27.40.2 --> Solaris 10
Server3 --> Iface1 --> 192.168.0.5 --> Solaris 10 --> Gateway
Iface2 --> 10.27.40.5
Now I am able to ssh... (36 Replies)
My distribution details.
# lsb_release -a
LSB Version: :core-3.1-ia32:core-3.1-noarch:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID: EnterpriseEnterpriseServer
Description: Enterprise Linux Enterprise Linux Server release 5.2 (Carthage)
Codename: ... (13 Replies)
Need help from the unix admins out there. I am trying to telnet from a windoze machine to a sun machine. It won't let me connect. I looked at etc/services and I found the port that telnet was listening on. But, how can I tell if its actually up and available? is there a unix command I can issue?... (15 Replies)
I'm becoming a dying breed where I work. More and more sys admins are advocating automatically restarting failed services such as tomcat, jboss, etc. I've always been against doing this except with buggy apps that can't be fixed or avoided.
My main argument is that I feel it's a trick used by... (9 Replies)
Hello Unix experts,
I am very new to shell scripting.However,I have been asigned a task in Unix-that I need to prepare a script which will check if OBI 10g and OBI 11g services are running or not and to send email if the services are down.In addition to it,I also need to check whether Weblogic... (12 Replies)
I had a doubt if any services need to be restarted if port no in /etc/services in an RHEL setup is changed. For eg, the port no of 443 for SSL may need to be changed.
I hope my query is clear whether any services need to be restarted if port no in /etc/services is changed.
Please revert with... (10 Replies)