NETWORKS(5) File Formats Manual NETWORKS(5)NAME
networks - network name data base
The networks file contains information regarding the known networks which comprise the DARPA Internet. For each network a single line
should be present with the following information:
official network name
Items are separated by any number of blanks and/or tab characters. A ``#'' indicates the beginning of a comment; characters up to the end
of the line are not interpreted by routines which search the file. This file is normally created from the official network data base main-
tained at the Network Information Control Center (NIC), though local changes may be required to bring it up to date regarding unofficial
aliases and/or unknown networks.
Network number may be specified in the conventional ``.'' notation using the inet_network() routine from the Internet address manipulation
library, inet(3N). Network names may contain any printable character other than a field delimiter, newline, or comment character.
SEE ALSO getnetent(3N)BUGS
A name server should be used instead of a static file.
4.2 Berkeley Distribution May 6, 1986 NETWORKS(5)
Check Out this Related Man Page
networks(4) File Formats networks(4)NAME
networks - network name database
The networks file is a local source of information regarding the networks which comprise the Internet. The networks file can be used in
conjunction with, or instead of, other networks sources, including the NIS maps networks.byname and networks.byaddr and the NIS+ table
networks. Programs use the getnetbyname(3SOCKET) routines to access this information.
The network file has a single line for each network, with the following information:
official-network-name network-number aliases
Items are separated by any number of SPACE or TAB characters. A `#' indicates the beginning of a comment. Characters up to the end of the
line are not interpreted by routines which search the file. This file is normally created from the official network database maintained at
the Network Information Control Center (NIC), though local changes may be required to bring it up to date regarding unofficial aliases
and/or unknown networks.
Network numbers may be specified in the conventional dot (`.') notation using the inet_network routine from the Internet address manipula-
tion library, inet(7P). Network names may contain any printable character other than a field delimiter, NEWLINE, or comment character.
SEE ALSO getnetbyaddr(3SOCKET), getnetbyname(3SOCKET), inet(3SOCKET), nsswitch.conf(4), inet(7P)NOTES
The official SVR4 name of the networks file is /etc/inet/networks. The symbolic link /etc/networks exists for BSD compatibility.
The network number in networks database is the host address shifted to the right by the number of 0 bits in the address mask. For example,
for the address 184.108.40.206 that has a mask of fffffe00, its network number is 803351. This is obtained when the address is shifted right
by 9 bits. The address maps to 12.66.23. The trailing 0 bits should not be specified. The network number here is different from that
described in netmasks(4). For this example, the entry in netmasks would be 220.127.116.11 fffffe00.
SunOS 5.11 17 Jan 2002 networks(4)
Changed from a broken Switch to a working HUB everyting else in my network is ok after the change but not my RS/6000! It refuses to get connected, get time out on Pings both ways - strange?
Could it be some problem with ARP?:confused: (2 Replies)
Just need a little help I'm not sure wat I should do.
We have several little networks setup for testing different things. One of these networks we need to have running at full dulpex.
Right now we run 2 hubs (to go off to 2 differnt parts) and they are half dulpex hubs.
Is is... (1 Reply)
I am running RH7.3 on a compaq presario box. The network card is a Linksys one. I am only able to communicate with the local network (only the local IPs are accessible). When I try to ping another box I get a "Connect: Network is unreachable" message. What could be the problem.
Thanks in... (2 Replies)
I have HP-9000 Server running HP-UX 10.20. rECENTLY OUR network upgraded to 100mb/sec and I want to do same on the server. So, I add the second Network card (100MB). But the problem is, I can't find a way of configuring this card. How am i going to tell the server to use this 100mb card... (1 Reply)
This is more of a personal problem. I work for a University and the Univ has given me an ip address range 18.104.22.168 - 22.214.171.124 for my lab. Every time I bring a computer for the lab, I have to ask the university to add the dns name to the dns server. Recently we have split up... (2 Replies)
Good morning folks,
A good friend of mine has a network where every host has two paths to the file servers (two NICs & two networks for all hosts).
Normally speaking, one network will be used for regular application traffic - license servers, itunes library, collaboration tools - while the... (4 Replies)
I am going to take up a position in Data & Network Security.
I would need to write network shell scripts doing the following task:
Going to around 2000 servers and findout which groups has access to each servers and which ids are there in each group that has access.
I need to implement... (1 Reply)
system config. Red hat ES 5 . multiple network cards. front end and back end networks.
Here is what I have diagnosed on linux 6 .....other machines on the network if you try to get there do not see linux 6, a ping results in “no route to host” message. However the system is running... (4 Replies)
I have question about VPN connection thats,
I have two networks
both are connected to internet
i have in Office network PPTP VPN Server with real or static ip and on the home network all clients working with local ip
I need to connect to... (3 Replies)
I am trying to restore a VIO server through HMC. The nim_resources.tar is nfs exported from a file server.
The HMC has 2 interface configured
ent0 - Privare network
ent1 - Public network
Both networks are isolated from each other with different switch.
Now the problem:
When... (2 Replies)
I've read about BITNET, CompuServe... CompuServe was probably not a network but an online service. Are (were) there any other networks alternative to Internet? Does anyone have experience with them? Do they still exist, is it possible to access them over Internet? There seems not to be another way... (13 Replies)
I have 2 p520 machines and created a vio server for each one (vio01 - vio02). I created 3 AIX 5.3 lpars on vio02 and 3 AIX 6.1 lpars on vio01. The problem is when 2 lpars are activated, i can ping gateway from both lpars and vio; but when i activate 3rd lpar, network downs and none of... (2 Replies)
I was really disappointed with The Social Network! I had no idea how it could win 5 golden globe awards (or whatever it won!). Granted, the actor who played Mark Zuckerberg, Jesse Eisenberg, did a good job playing a socially inept smart guy; but for me, the rest of the movie was not very... (5 Replies)
I'm working as a DBA and DB is installed on linux os. I am wrtting a health script to check if any errror in network is there or not or all required parameter which required to be checked from DB perspective on OS. Also i would like to add TSM, Data domain information for Backup... (1 Reply)