NGE(4) BSD Kernel Interfaces Manual NGE(4)
nge -- National Semiconductor PCI Gigabit Ethernet adapter driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The nge driver provides support for various NICs based on the National Semiconductor DP83820 and DP83821 Gigabit Ethernet controller chips.
The DP83820 supports TBI (ten bit interface) and GMII transceivers, which means it can be used with either copper or 1000baseX fiber applica-
tions. The DP83820 supports TCP/IP checksum offload and VLAN tagging/insertion as well as a 2048-bit multicast hash filter and up to 4 pat-
tern match buffers.
Most cards also use the DP83861 10/100/1000 copper gigabit transceiver chip, which supports autonegotiation of 10, 100 and 1000Mbps modes in
full or half duplex.
The DP83820 and DP83821 also support jumbo frames, which can be configured via the interface MTU setting. Selecting an MTU larger than 1500
bytes with the ifconfig(8) utility configures the adapter to receive and transmit jumbo frames. Using jumbo frames can greatly improve per-
formance for certain tasks, such as file transfers and data streaming.
The nge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media
options to rc.conf(5).
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or
1000baseTX Set 1000baseTX operation over twisted pair. full-duplex and half-duplex modes are supported.
1000baseSX Set 1000Mbps (Gigabit Ethernet) operation. Both full-duplex and half-duplex modes are supported.
The nge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The nge driver supports National Semiconductor DP83820 and DP83821 based Gigabit Ethernet adapters including:
o Addtron AEG320T
o Ark PC SOHO-GA2500T (32-bit PCI) and SOHO-GA2000T (64-bit PCI)
o Asante FriendlyNet GigaNIX 1000TA and 1000TPC
o D-Link DGE-500T
o Linksys EG1032, revision 1
o Netgear GA621
o Netgear GA622T
o SMC EZ Card 1000 (SMC9462TX)
o Surecom Technology EP-320G-TX
o Trendware TEG-PCITX (32-bit PCI) and TEG-PCITX2 (64-bit PCI)
The following variables are available as both sysctl(8) variables and loader(8) tunables:
Maximum amount of time to delay interrupt processing in units of 100us. The accepted range is 0 to 255, the default is 1(100us).
Value 0 completely disables the interrupt moderation. The interface has to be brought down and up again before a change takes
nge%d: couldn't map memory A fatal initialization error has occurred.
nge%d: couldn't map ports A fatal initialization error has occurred.
nge%d: couldn't map interrupt A fatal initialization error has occurred.
nge%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization.
nge%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in
a bus-master slot.
nge%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization.
nge%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
altq(4), arp(4), miibus(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)
National Semiconductor DP83820 datasheet, http://www.national.com.
National Semiconductor DP83861 datasheet, http://www.national.com.
The nge device driver first appeared in FreeBSD 4.4.
The nge driver was written by Bill Paul <firstname.lastname@example.org>.
November 23, 2010 BSD