ISPFW(4) BSD Kernel Interfaces Manual ISPFW(4)NAME
ispfw -- Firmware Module for Qlogic based SCSI and FibreChannel SCSI Host Adapters
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
This trivial driver provides access to firmware sets for the Qlogic based SCSI and FibreChannel SCSI Host Adapters. It may either be stati-
cally linked into the kernel, or loaded as a module. In either case, the isp(4) driver will notice that firmware is available to be down-
loaded onto Qlogic cards (to replace the usually out of date firmware on the cards). This will kick the f/w into getting unstuck.
SEE ALSO isp(4)AUTHORS
This driver was written by Matthew Jacob.
BSD July 20, 2000 BSD
Check Out this Related Man Page
ISP(4) BSD Kernel Interfaces Manual ISP(4)NAME
isp -- Qlogic based SCSI and FibreChannel SCSI Host Adapters
isp* at pci? dev? function? (PCI)
isp* at sbus? slot ? offset ? (SBus)
scsibus* at isp?
This driver provides access to SCSI or FibreChannel devices.
SCSI features include support for Ultra SCSI and wide mode transactions for SCSI, and LVD (for the ISP1080 and ISP1280),
Fibre Channel support uses FCP SCSI profile for FibreChannel. and uses Class 3 connections only. Support is available for Public and Pri-
vate loops. Command tagging is supported for all (in fact, FibreChannel requires tagging).
An optional flags 0x80 appended to the above isp* declarations will disable the download of driver firmware, which means you use whatever
firmware is running on the card. If no firmware is running on the card, the driver cannot operate the card.
An optional flags 0x40 appended to the above isp* declarations (can be OR'd in with the other config flags option) will keep the driver from
looking at device or bus NVRAM settings (this is in case NVRAM is just wrong and you have the card in a platform where it is inconvenient to
change NVRAM settings on the card).
Supported cards include:
SBus Fast Wide, Ultra Fast Wide cards, Single Ended or Differential cards.
Performance Technology ISP1000 variants.
Qlogic 1020 Fast Wide and Differential Fast Wide PCI cards.
Qlogic 1040 Ultra Wide and Differential Ultra Wide PCI cards.
Performance Technology ISP1040 variants.
Qlogic 1240 Dual Bus Ultra Wide and Differential Ultra Wide PCI cards.
Qlogic 1280 LVD Ultra2 Wide PCI cards.
Qlogic 1280 Dual Bus LVD Ultra2 Wide PCI cards.
Qlogic 2100 and 2100A Copper and Optical Fibre Channel Arbitrated Loop
Qlogic Dual Loop 2100A Optical Fibre Channel Arbitrated Loop PCI cards.
Qlogic 2200 Copper and Optical Fibre Channel Arbitrated Loop PCI cards.
Qlogic 2200 Dual Bus Optical Fibre Channel Arbitrated Loop PCI cards.
Qlogic 2200 Quad Bus Optical Fibre Channel Arbitrated Loop PCI cards.
Qlogic 2300 2-Gigabit Optical Fibre Channel PCI cards.
Qlogic 2300 2-Gigabit Dual Channel Optical Fibre Channel PCI cards.
Performance Technology ISP2100 variants.
Antares Microsystems ISP2100 variants.
Qlogic 2400 4-Gigabit Optical Fibre Channel PCI cards.
Qlogic 2500 8-Gigabit Optical Fibre Channel PCI cards.
SEE ALSO cd(4), intro(4), scsi(4), sd(4), st(4)AUTHORS
The isp driver was written by Matthew Jacob for NASA/Ames Research Center.
The driver currently ignores some NVRAM settings.
The driver currently doesn't do error recovery for timed out commands very gracefully.
Sometimes, when booting, the driver gets stuck waiting for the Fibre Channel firmware to tell it that the loop port database is ready. In
this case you'll see an announcement that the loop state has a value of 0x1. To unwedge the system, unplug and replug the fibre channel con-
nection, or otherwise cause a LIP (Loop Initialization Primitive sequence) - this will kick the firmware into getting unstuck.
BSD June 24, 2009 BSD